Pergunte aqui
0

Gostaria de saber como o PROCV faz a pesquisa para termos repetidos.

perguntadas 2016-09-13 15:24:59 +0200

imagem do gravatar de dpan

Tenho uma lista em que um mesmo valor se repete na primeira coluna e é diferente na segunda.

Queria saber se tem como diferenciar os valores, de forma que apareça cada um.

Segue a imagem : Descrição da imagem

Eu queria digitar por exemplo A , de forma que apareça : 52,55,56 , podendo ser assim ou separado em células diferentes, mas de forma que apareçam todos.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2016-09-13 23:09:32 +0200

imagem do gravatar de Leandro Vieira

updated 2016-09-16 19:34:59 +0200

Sobre a função PROCV, descrevê-la nesta resposta gastaria muito espaço, acho melhor dá uma olhada no menu de AJUDA do LibreOffice digitando no campo de pesquisa da aba LOCALIZAR a função referida.

No seu caso ela somente serviria para fazer a primeira busca nas demais siga o exemplo:

Descrição da imagem

Na célula $F$2 insira a função =PROCV(E2;$A$2:$B$8;2;0)

Na $F$3 utilize =SE(E(DESLOC(INDIRETO(ENDEREÇO(CORRESP($E$2;$A$1:$A$8;0);1));1;0)=$E$2);DESLOC(INDIRETO(ENDEREÇO(CORRESP($E$2;$A$1:$A$8;0);1));1;1);"")

E por último na $F$4 cole =SE(E(DESLOC(INDIRETO(ENDEREÇO(CORRESP($E$2;$A$1:$A$8;0)+D4;1));1;0)=$E$2);DESLOC(INDIRETO(ENDEREÇO(CORRESP($E$2;$A$1:$A$8;0)+D4;1));1;1);""), depois arraste a fórmula para as demais células.

Observações:

As referências $A$1:$A$8 e $A$2:$B$8 são dos intervalos para as consultas, ou seja, seu banco de dados, neste caso altere a seu critério.

Não utilize utilize um critério de Procura diferente dos Dados, exemplo utilizando letras minusculas na pesquisa enquanto nos dados são maiúsculas, no meu aqui deu erro.

Siga o layout da imagem colocando a sequência de números da coluna D até onde você achar necessário, neste exemplo utilizei até o número 4, mas dependendo do caso pode ser bem mais.

Outro sim, a busca foi feita considerando que os DADOS estão classificados em ordem crescente.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2016-09-17 02:22:44 +0200

Pode ser com Tabela Dinâmica?

  1. Aproveitando a Tabela de @Leandro Vieira;
  2. Só mudei o Titulo da coluna A (p/ Nomes) para não confundir a Tabela Dinâmica;
  3. Selecione a área (no exemplo A1:B8)
  4. Menu Inserir / Tabela dinâmica... Seleção atual OK
  5. Veja a imagem: Descrição da imagem
  6. E o resultado é este: Descrição da imagem
editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2016-09-13 15:24:59 +0200

Lidas: 464 vezes

Última atualização: Sep 17 '16