Ask Your Question
0

How to avoid English auto-correction in other languages? [închis]

întrebat 2015-11-13 09:36:24 +0100

imagine gravatat cipricus

updated 2016-03-01 13:22:44 +0100

Although spell-check for Romanian is enabled and the auto-correct options should follow that spell-check language, what happens is that i is changed automatically (auto-corrected) to I just like in English. A such auto-correction is not present for Romanian. It is for US English.

image description

image description

If I want to write something like Ei i-au spus ("They told him"), when I write - after i the auto-correction produces I- (the same letter but uppercase) instead of i- and I get the incorrect if not biblical Ei I-au spus ('They told Him', as if 'they' were talking to God.) It is in fact the English auto-correction from i to I (like in I am).

image description

Also, i is changed to uppercase after clicking space after it (only that i alone is not a word in Romanian.

image description

I have tested with different common fonts. It does not seem font-related.

edit retag flag offensive reopen merge delete

Closed for the following reason întrebare duplicat by cipricus
close date 2016-05-02 18:41:26.527966

Comments

related: on Spanish

imagine gravatat cipricuscipricus ( 2016-03-01 16:22:55 +0100 )edit

marked as duplicate of the one mentioned above

imagine gravatat cipricuscipricus ( 2016-05-02 18:42:03 +0100 )edit

2 Answers

0

răspuns 2016-03-01 14:06:25 +0100

imagine gravatat cipricus

updated 2016-05-02 18:34:52 +0100

First: UPDATE. Version 5.1.2.2 doesn't seem affected by this already.


In this answer I got a solution for my older version:

set Romanian as default in Options - Language Settings - Languages - Default Languages for Documents

image description

To me this looks like a bug. Now I can even roll back to English US for default language for documents and if I change a paragraph language to Romanian the problem is absent. Odd, like a small bug fixed by changing at least once the English US default language for documents.


On the older version (4.7) a different word was being replaced with the English form no matter the changes above (Excelent became Excellent). In case this kind of problem happens in any case there is the more radical solution of disabling 'Use replacement table' - 'Autocorrect while typing' under 'Tools - AutoCorrect - AutoCorrect options', Options tab. (To select the language first go to the 'Replace' tab.)

image description

edit flag offensive delete link more
0

răspuns 2016-01-13 15:19:25 +0100

imagine gravatat ipse

I'm not sure i understand your question. Can you be more explicit, please? Just in case, make sure your entire text is written in romanian language (select it all and go to Tools menu, Language Command, For Selection Subcommand, and select Romanian language option. Or, it could be a font issue. As you probably already know, some (older) fonts are not rendered correctly in Romanian language,and LibreOffice tries to render them to the most accurate replacement. The font issue is universal, it's not LibreOffice specific. It happens in MS Word too. Just try a different font, like Google Noto (NoTofu).

edit flag offensive delete link more

Comments

i can confirm this happens no matter the font in LO 4.3.2 in Linux Mint 17.2. I will complete my question with more images and details: ”i” is automatically changed to „I” no matter the font. This is done by auto-correction when writing ”-” after ”i”.

imagine gravatat cipricuscipricus ( 2016-03-01 12:37:00 +0100 )edit

sorry for the initial wrong and incomplete posting. I have tried to correct and complete it. I will add more details.

imagine gravatat cipricuscipricus ( 2016-03-01 12:45:07 +0100 )edit

added gif animated image for details

imagine gravatat cipricuscipricus ( 2016-03-01 12:56:15 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2015-11-13 09:36:24 +0100

Seen: 217 times

Last updated: May 02 '16