2 Minute Loading time for tiny calc file

Hi guys,
I have really strange issues with some calc-files. They do not contain a lot of information but still need several minutes to open. The file I currently work on has a single table with about 50 rows, 5 columns, and 2 diagrams. It takes 2 minutes at 100% CPU usage of my Intel i7-4770K (one core only).

I tried several computers, and two versions of Calc. First, the version that comes with Ubuntu 16.04, which is 5.1 if I am not mistaken. And then also via ppa.

I also tried do disable certain loading features and also tested older LibreOffice-file-formats. All without success.

Anyone else ever experienced something like that?
Any idea how to solve this issue?

Thanks a lot in advance!

Is content of the file sensitive? Could you post it somewhere - strip sensitive info first! - and paste link to the file here so others can check it? If you make bug report, developers will also like to see the file. Best make it available here first so more experienced users could point you in the right direction.