4k Screen LibreCalc Scaling


I’m running (x64) on windows 10 version 1703 build 15063.632

My machine has a 4k screen and I have really bad scaling issues using libre office calc. For example, the point that the mouse cursor points hovers over is not the point that gets selected when I click. So if I click on a cell, then a cell two up from that cell is selected instead. The menu bar is also not visible - the bar with File, Edit etc… on it.

Is there a setting I can change to fix this, calc is pretty much unusable? I’ve tried all the windows scaling override settings.

Please test if changing OpenGL option Menu/Tools/Options/LibreOffice/View.

Hi, thanks for your response. Changing the opengl option makes no difference the problem persists with opengl enabled and disabled.

Have you set up some scale on the screen configuration?

If you mean the windows screen configuration, no I’m using the recommended scaling that it defaults to. 250% on my 4k monitor and 100% on my HD monitor. Moving the app between the monitors makes no difference.

Have you tested changing the screen scale from 250% to a lower value like 100% or 150%?

Tested changing the scale to 100% on the 4k screen. It doesn’t make a difference.

Try updating video card driver.

latest nvidia and intel drivers already.

Then please report the bug LibreOffice feedback, add in the report the file C:\Users\USUARIO\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

Exact same problem here. No idea how to easily create documents apart from buying MS office.

I had exactly the same issues as the original poster. My issue was resolved by going to Menu / Tools / Options / LibreOffice / View and unchecking Use OpenGL for all rendering, as mentioned. This was difficult to perform, however, because the menu bar is not visible in the main interface. You must click at the top of the screen and move the mouse along until you find the ‘Options’ entry. Furthermore, in the options window, you can’t even see the LibreOffice node because it is at the top.

I don’t have this issue with Libre Office but I have similar issues with Adobe application cursors not behaving as they should if I have windows scaling options too high or too low for that application. I use large 4k screens and sit a good 3 meters from them so I need to increase text scaling otherwise text and other things are microscopic and can’t be read or they don’t display correctly. Try turning your operating system scaling options up or down, test that out.
I have to use weird numbers on some of my screens so everything is legible and works right.

There isn’t a whole lot of content for 4k technology and the technology it self hasn’t been mastered yet. Most applications, movies, and games are not designed to run in 4k resolutions and scaling. For that reason it really doesn’t provide any benefit, more issues than anything, to use 4k settings. I work with multiple applications and coding often. It’s useful for me to be able to have as many windows visible and accessible on one screen as possible. I don’t use 4k settings because the scaling is screwy and it makes cursors behave weird like you’ve described.

It’s scaling because the app, and many apps, are not designed for the resolution you’re using. If scaling doesn’t work you’ll have to resort to using a larger scaled resolution, not a 4k resolution, as I did because I had to because of the same kind of issues.