5.1 won't load ANY document

Just installed 5.1.0 on Windows 7. I did not uninstall my previous version. I rebooted my machine, just in case.
5.1 won’t load ANY of my LibreOffice documents!!!
I’ve tried the spreadsheet, word processor, and presentation programs and the behavior is always the same.
The app will open. I see the window and all of the buttons and menus etc. But the document never loads into the main window. It just sits there forever with an empty pane.

Anyone else seen this? Any idea how to fix it. I use LibreOffice all day every work day and I am stuck until I can get this fixed. I’ll have to reinstall the previous version if I can’t get this fixed.

Calvin Powers

Just noticed that new documents I create on the Windows desktop have the same behavior. Window opens i see most of the controls in the window, but the pane never fills in with a new document to edit. Just a blank pane.

I am experiencing the same issue, I tried to reinstall it but it is always the same. I am going to uninstall it and try the still version, I will let you know.

Same problem for me.
I tried to uninstall it all, delete my profile settings, and reinstall, but problem remains.

Have you found a solution?

I just downloaded and installed LibreOffice (x64 version for Windows 7 Pro 64-bit). I am unable to open ANY files. ODF, ODS, ODP – nothing will open. It won’t open DOCX either. Just get a blank windows. NOTHING displayed. Menus usually show up

Wow. What a complete piece of SH*T and complete letdown. How could this software have been released with such blatant problems. I’ve been using LibreOffice since it forked from OpenOffice. 4.4.x was good. Such a disappointment.

I tried 5.0.5, (beta) both 32-bit and 64-bit of both as well as 32-bit version of 5.1.0. NONE worked. NONE would display. Sometimes the menus functioned, other times they did not (e.g. File > Exit LibreOffice failed to close the window OR exit LibreOffice.)

I re-installed the 32-bit version of LO 4.4.2. At least that still worked.

I don’t know what happened, but opening an attachment in one of my emails, now it works fine. Anyway, I update to 5.1.1 beta version and it is still ok.