500 page novel will not maintain page format

I am trying to upload my second novel (170,000 words, 500 pages, 12pt Font) to CreateSpace for publishing as a paperback and Kindle Book, but my OOWriter will not keep the Page Format I have used.
I am trying to create a 6"x9" inch Paperback. Margins are Inner=.76", Outer=.46", Top and Bottom=.36".
My files, ODT, PDF, DOC and DOCX all keep Changing Pages 301-500 to In=.75", Out=.75", Top&Bottom=.75".
My first novel was 79,000 words, 290 pages it worked fine.
I’m using LibreOffice, Ver, Build ID 40.m0(Build 2), en_US.
My OS is Linux Mint 17.2, Cinnamon Ver 2.6.13, 64 bit, Linux Kernel 3.16.0-38-generic, using 1.9 GB Memory.
Can you help?

The basic dimensions in LO are inches and there can be small variations when inch measurements are converted to mm and vice versa.

The differences are probably word line spills and page spills due to slightly different page formats.

As a workaround, insert redundant Insert > Page … These prevent any spillage crossing such a new page.

Always work in .odt and do not change between .odt and .doc or .docx.

Check the Format > Page > Page > Margins and p 300 - is p301 different?

A different page template could have different margins.

Check to see which page template is used on those pages.

A section could have different margins.

Check in the Navigator to see if those pages are in a different section.

Thanks for the reply, but…
I don’t understand “Check in the Navigator if pages are in a different section”.

Search Help for Navigator.

The only way a margin or a header/footer (or a difference to page number) can change is at a place where the Page Style changes.

Place the cursor in a page - the page style for that page is shown at bottom left.

Set Options > ?? > Appearance > Section Boundaries > Page and column breaks …, to a highly visible colour like RED. All page breaks now show as a thin red line.

You may find AOO more stable than LO for large documents.

Always save the file as a .odt - never use other file formats.

“Place the cursor in a page - the page style for that page is shown at bottom left.”
When I do as you say, nothing happens or shows!?
Thanks for you r reply.