6.3 on Windows 10 fails after installation

I have used Libreoffice in the past. I installed 6.3 on Windows 10 (64 bit) and it failed on launching after installation.
Fatal error:
The Application cannot be started. Unexpect com.sun.star.registry.invalidRegistryException: com.sun.star.registry.SimpleRegistry.open(file:///C:/Users/myusername/AppData/Roaming/LibreOffice/4/usaer/uno_packages/cache/regisry/com.sun.start.comp.deployment.component.PackageRegistryBackend/Windows_X86_64_.rdb): underlying Registry::open/create()=6

Note: I also tried to reinstall after uninstalling all Libreoffice entries in program add/remove(there was the 6.3 and a help program from a few versions ago)

Try resetting user profile.

Mike, I tried that and it seems to have worked. A few followup questions:

  1. Should I report this in bugzilla and if so ow?
  2. Is there any way to get back any any part of my previous settings, Truthfully, I don’t even know if I had any.

And, thank you very much for your help!

  1. This only need to be filed as a bug if you can describe how to reproduce the profile corruption from clean profile. Unfortunately, most profile corruptions happen with unknown event, and the result is random - which itself isn’t worth any debugging.
  2. I’d suggest not to try importing any - esp. if you don’t know if you had them. Starting from clean list allows you to avoid any obsolete settings inherited from older versions, which could have been replaced with something new since then. Anyway, all the settings are in registrymodifications XML file in your profile, so in theory, you can try reading that XML and take the settings one-by-one.