64-bit LibreOffice-5.1.5 & 5.2.0 freeze/hang while opening files


Previously I had 32-bit LibreOffice-4.4.7 on my 64-bit Windows 10 laptop, and it was working fine.

Later I tried using 64-bit LibreOffice-5.1.5 & 5.2.0, but they both freeze/hang while opening (double clicking) associated files or while launching any LibreOffice app (calc writer, etc). Deletion of user profile and installation repair didn’t fix the issue. I made sure Java 64 & 32-bit and Python 64 & 32-bit were installed before the 64-bit LibreOffice installation.

Frustrated, I installed 32-bit LibreOffice-5.1.4, and it is working fine. But I want to use 64-bit LibreOffice. Can somebody advice me on what I should do to get 64-bit LibreOffice working on my laptop. Please let me know if you need more info, logs, etc.

BTW, is 64 bit-LibreOffice known to have problems or is unstable or is not full-featured or is not recommended?


I started a thread about the same problem. Since it’s still unresolved as of the 64-bit release, I’ve also reported bug #105084.

Yep, I had the same problem. Reinstalling 32bit version solves it.

I experience this problem with LibreOffice running on OS X 10.10.5 on a MacBookPro. The cpu runs at 100% capacity for several minutes and the app is non-responsive, before returning control to me. All other apps are responsive. A sample of what it is doing during this time can be found here:

Hope somebody out there understands and can read it!! This typically occurs after a sleep wake up.

Follow up - while reporting this as a bug was made aware of the User Profile problem that sometimes develops - delete this file (~/Library/ApplicationSupport/LibreOffice/4/user) and the problem goes away - at least for now…

Your post proved to be the solution for me as well. Although some of my client’s execs have upgraded to Macs, most of the staff are still chained to Windows. LibreOffice 5.2 64bit works perfectly on Windoze 7, but Windoze 8.x doesn’t like it. I was relieved to find that the 32bit version of 5.2 works on 8.x, thanks to your post. There are a number of things that were broken by the different security system of Windoze 8.x, and they will probably affect those users who are stuck with Windoze 10 as well.
Thanks for taking the time to post your experience.

I had the same or similar problem with 5.2.3 64 bit. The logo would display but it would hang. It was consuming CPU cycles but never completed the launch. A reinstall did not fix it. So I tried the 32 bit version and it worked fine.


I was having this issue on a laptop running Windows 10 x64 on an Intel Core i3 Processor. What was annoying me is that I had two other users running on fundamentally the same hardware (different generations of Core i3) and having no issues, but this laptop just wouldn’t go beyond opening the LibreOffice window.

I looked through the Add/Remove Programs list to try and see if I had any variation in software installed and had a hunch it had to be processor related. The only processor related software I could find that was on this laptop but not on the other systems was an Intel OpenCL SDK (I can’t quite remember exactly what it was listed as in Add/Remove programs, something like OpenCL 1.1 for Intel Core Processors). I have just removed it and LibreOffice (x64) now works again!

If you’re having this problem, check for OpenCL for your Intel Processor. With the increasing use of Intel’s integrated graphics on most systems, there is a chance this is the problem in a number of cases.

Hope this helps.

Uninstalling Intel OpenCL SDK solved LO6 hang on a new installation for me. I have installed LO6 on at least four computers (2 AMD and 2 Intel a desktop and a laptop) three of the installations were fine whereas the HP/Intel laptop would hang with “not responding” upon opening LO6. “Allow an app trhough Controlled folder access” paved the way to solving t he problem (relative to Windows Event log Event ID 1002 - soffice.bn “stopped interacting”) then uninstalling OpenCL SDK stopped the hang.

I am running LibreOffice on a Windows 7 Home Premium system (64 bit) with 20GB RAM.

Installed LibreOffice a month ago and it ran fine for a while. Then, a couple of days ago I could not open
LibreOffice Draw. It hung up on the opening splash ‘LibreOffice 5,’ and stayed that way for hours. I tried a
couple of fixes from the web, one of which was to remove indexing from the C: drive. That did not work.

What DID work was to run a ‘Repair’ on LibreOffice.

1) go to 'Start,' 'Control Panel'

2) find 'Programs and Features'

3) find the installation of LibreOffice and Right Click on it, 

4) Three options should appear a. Uninstall b. Change c. Repair
	Select 'Repair.'

5) LibreOffice will run through several operations and then request a reboot.

6) Once rebooted, attempt to reopen LibreOffice.

For me, this worked perfectly and I was able to work with LibreOffice Draw again.



I have got the same “Hang” problem. I double click a document the window frame opens but stays blank for several minutes. I have tried

  • uninstalling 64 bit and installing 32 bit
  • repair
  • uninstall OpenCL

Nothing helps !
I use a Lenovo X1 with windows 10 (latest update)