A way to disable header/footer

Is there a way to disable header/footer so no matter how many times I click on the empty space where they are supposed to be they don’t show up?
The reason for this is that I don’t use it in most documents but I click to and from the document a lot. When I accidently click in the “wrong” place and footer activates it lags out the whole document for a few seconds.
I could double click between the pages hiding them but that has its own downsides.

To give a really meaningful answer, edit your question (don’t do it in a comment, so that your question is self-sufficient without the need to track a conversation through comments) to add LO version and OS name. Also, have you customised the default template?

It is hard to understand your question because header and footer are not enabled in the factory configuration of any page style. But all page styles have some margins.

When you click in the margins, nothing show up because there is nothing to display but you may cause some contextuel pop up (like a shortcut to add a header ; shortcut because you don’t need to go through all the technicalities of a page style).

For a really good answer, explain why you click outside the document but, if I understand right, inside the Writer window.

Yes, you can turn it off.

2022-08-14 16 06 17