Access denied for user 'Root'@'[my machine name].LOCAL' (using password: YES)

I have a MySQL database on a server that I’m trying to access from my local machine using Base. I keep getting the error message that is the title of this thread. When I go to “More”, I see “SQL Status: 28000
Error code: 1045”. I’ve been accessing the db through the CLI frequently, so I know I have the user set up correctly for remote access, and I’m certain I’m using the correct username and password.

Version: (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

I can’t figure out why Base is behaving differently from the CLI.
I’m using the mysql-connector-java-5.1.44. Anyone have any suggestions?

Addendum: I’ve done a little experimenting, and any other user can log in through the same .odb/connector configuration. Also the ‘Root’ user can log in through the CLI.
Second Addendum: I’ve also tried creating a new.odb file connected to the same server, and it would not connect, even with a login that is working in my working .odb file.

Have a look at Edit → Database → Properties → Connection Settings. There must be defined a server.

If the sever is your local system, like it is on much Linux-systems, server is “localhost”. Could also be a IP-address.

It’s the IP address of the server that hosts the MySQL database (on my local network), the same IP address I use when logging in as Root through the CLI.The version of MySQL on that server is 5.7.19. Any reason a login attempt from Base by way of the connector would be treated differently than a login by way of the connector, or why it would not work anymore, when I used to use it semi-regularly? I tried a different user’s login from my machine, and it connected successfully, so that seems to rule out problems with the server, with the connector, with the .odb file configuration, or any compatability issues therein.

I have looked at my own installation. Only person, which I have allowed to connect from other destination than “localhost” is one special user. The user “root”, “mysql” and others are only allowed from “localhost”. So have a look at your MySQL-installation. I’m using phpMyAdmin for this, because I’m also creating databases with a php/Apache/MariaDB.

Thanks! That is not the case in my installation. I’ve been logging into the ‘Root’ account from the CLI on a client machine. (It’s the same client machine on which I’m running Base.)

You always write ‘Root’. Are you shure it is right with capitalized ‘R’? Here it is ‘root’ - and other descriptions will also show it lowercased.

Oh, I feel so foolish! You’re so right! I had set up a shortcut to pull up the CLI for root, and I had put “as Root” in the shortcut name, which showed up in the window title bar every time. I frequently would look at that to see which user’s window I had. I’m changing the name right now, so I can avoid future confusion.