Add to dictionary is grayed out

I have the following configuration:

  • MX Linux 19.4
  • LO 7.0.1.1 (base language English UK, added Spanish speller)
    I have a document, changed language to Spanish, the speller seems to be working (only few red underline), when I tried to add words to dictionary, the button is grayed out, what did I miss?

It works for me with Dutch and English. Are any other buttons greyed out as well? Very often, resetting the user profile solves problems like this. See LibreOffice user profile - The Document Foundation Wiki for help. Note: you rename the old profile, so your user settings are safe, and you can later copy them from the old profile to the new one. Do that when LibreOffice is not running.

@floris_v thanks so much for this tip, it worked, how can I get my old configuration back? Can I just copy old folder over the new profile?

Read the entire article; it offers help for restoring usable parts of your old configuration. If you copy the entire old profile, you will get your problems back.

Understood, thanks again for this tip.