Add to dictionary not removing the red underline

most of the time it works just fine but I have two words that still have the red underline even after ignore or add to dictionary.

also to be more specific since I found a thing about i. when the word has " 's " attached to it the spellcheck refuses to remove itself even when the word was added to the dictionary

Have you checked the language setting (select, right-click then Format Cells-Numbers tab) for those cells or simply marked them all and set them to what you need? [Or checked them with MRI.] Have you tried pasting those cells into a new spreadsheet using Paste Special-Text? If you still get the same result, what operating system and version are you using? This would be to suggest guidance on how to examine the user dictionary file, although Tools-Options-LibreOffice-Paths will show you the basic information on the dictionary files. On my Linux system the user dictionary is


This can be examined using any regular text editor.

I never touched the language within format cells so its English USA, even after special pasting into a new excel sheet the underline still occurred. I use Windows 10 and the version I’m using is

Of course, that’s not a stable version. What are the words? I’ll try it on on Windows 10.

the words are Yoshi’s and JoJo’s

I can confirm in that:

  1. Words in the default English dictionary are not underlined in wavy red whether or not 's is affixed.
  2. Words not in the default English dictionary can be added in the form with 's or without 's or both, but no matter, while they are in the user dictionary file, they still are underlined in wavy red if 's is affixed.

This appears to be a bug, or at the very least a massive inconvenience to English users.

Do you want to file a bug report? If not, let me know and I’ll file one.

you can go ahead and file it. thanks for helping me out. it is a minor inconvenience but if there is a way to purge the issue that would be fantastic