After Update to Ubuntu 18.04 LTS

My current system is
Libre office Version:
Build ID: 1:6.0.6-0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-GB (C.UTF-8); Calc: group

Since the upgrade my toolbar ont the top of LOWriter looks like this

in other words the icons have become invisible , and thatś a nuisance
where can I adapt the settings in LO or do I need to do something in Ubuntu ?

I don’t have your version of LO but if you right-click somewhere on the LO toolbar, but not on an item there, you should get a menu, including Customize Toolbar. Under that might be Toolbars, and under that should be a choice of show only icons, only text , or text + icons. Give it a try.

Thanks for your answer, therw is no context menu for the toolbar, but there are settings in customize I could not change the colour of the icons but when i switched my Ubuntu screen settings to a dark colour theme it showed the icons were in white

Click Tools>Options>LibreOffice>View. There at “Menu” and “Icons in Menus”, choose Automatic and OK.

There are some options here:

  1. Some icons are missing in the default iconset. To test, try changing to a different icon set in the same place as @Hrbrgr mentioned (Tools>Options>LibreOffice>View). If it’s so, then please check for icon packages possibly missing in your OS package manager.
  2. Some bug related to used gtk3 vcl plugin. You might check it using SAL_USE_VCLPLUGIN environment variable set to, say, gtk2, like described here.
  3. A bug not related to vcl plugin. With any bug, vcl-related or not, you might want to test a newer version (which is currently 6.0.7 or 6.1.3); you may use the Ubuntu LibreOffice packaging team’s PPA for that.

thanks I downloaded some extra ubunut themes and icon sets and tweeked my settings using unity-tweaker, now i can see the “invisble” icons in my toolbar

Thnaks matter is solved with some extra Ubuntu themes and icons an using Unity tweak

It would be helpful for others if you edited the answer to mention the specific packages and settings (and their values) you modified

I reinstalled and updated Unity, and unity tweak , then i downloaded some extra sets of icons and themes and selected one that use ofher colours for icons and background and that just did the trick