after updating to ubuntu 14.04 all my libreoffice (writer-calc-draw-impress) can't write in arabic how can i fix that

my operating system is in english but even when i applied arabic system wide the office still won’t write in arabic
my office version is 3.a
please i have work postponed and i need help asap
when i open a saved file the pages appears blank but when i copied it to my gmail the words are there

Please, verify that you have enable the option in:
Menu/Tools/Language settins/Language/Default Language for Documents - Complex text layout.

i tried but it didn’t work
thanks any way

Other thing that you can try is resetting the user profile:, sometimes solves strange issues.