Age old 'File locked by unknown user'

I am ready to loose my mind here. I have a small office with Windows clients and a FreeNAS network storage server. The issue is that while a file is not open on any machine in the office, we will still get the ‘file locked by unknown user, open copy or read only’ if it’s opened by a different user than the one who created it. there are no lock files on the nas. I have tried to edit the soffice.bin script file but can’t find the section refered to by the readme: export SAL_ENABLE_FILE_LOCKING

What can I do here? If this is the issue I see no reason to even have a nas if multiple users can’t work on files. I have spent hours looking for answers online and am not finding one, only questions.

This looks like a Windows file ownership problem as the creator can open the file but not other users.

How is file security controlled on the nas server?

It may have to do with mounting the NAS - LibreOffice often doesn’t play well together with the NAS file locking system. On Ubuntu, I’ve fixed “open read only” issues by adding the “nobrl” flag to the mount option (see for an explanation of what this is doing and why it’s needed - basically it disables incompatible lock requests from being sent to the NAS).

Not sure how you’d do this in Windows, but it might help point you (or another reader) in the right direction.