All cells n all sheets are auto-formatted to Text. How to stop and change to numbers format?

Running OpenSuse x64 42.2 Leap. After a number system/application update all my sheets have a auto-text format for all previously formatted number cells. I have un-installed libreOffice and all related dependencies. Then re-install through OpenSuse Yast. This installed the latest version. Sadly when I open any sheet, all cells that previously had a number are still formatted as text. Have deleted or turned off all macros that I can find. Nothing seems to change the automatic text formatting. It takes about 1.5 -2 seconds for the entered number to change to blue and control returned to the keyboard.

Any advice or ideas will be tried.

If you go ‘File’>'New>‘Template’ : Is there a template for spreadsheets marked as ‘Standard’. If so you may reset the standard to default via the context menu of the emphasized template.
You can also edit that template and set all the cells to default cell format. Check also if the ‘Default’ cell style has the settings you want under ‘Numbers’.
Template saved again should do now as expected.

Problem solved.
Within linux local user space, turned on hidden-files. Under the hidden .config directory found and renamed the existing libreOffice directory which holds all local user libreoffice suite configuration files. These are created new when first run.
I did find a few scripts related to changing numbers to text within the old libreoffice directory. Renaming these scripts or renaming them did not fix the auto-reformat issue. So just forced the creation of all default settings with the above folder rename.