all documents are in read only how to fix

In a text document, my “dashes” are underlined in red, and sometimes the dictionary will correct them for me, but other times it won’t. It would be nice to be able to insert the proper dash, and my laptop doesn’t have it on the keyboard.

If anyone is able to shed some light on this, I will be grateful.

Thank you!

This question is not related at all with the title (read-only topic). Is it a different one?

Update your question, please. You are contradicting yourself by going off of your own choice of topic.

I apologize for the confusion that I caused. I don’t know how I managed to combine two separate questions into one post, but in future I will pay very close attention to what I’m doing while here. Thank you again for posting your comments!

I answered my own question re: the “read only” question. For some reason, every Writer document was opening in read-only, and when I closed the banner at the top of my document, I could edit the document, but had to save it with another name.
I fixed it at the folder level; I right-clicked the folder, chose Properties, then un-checked the box that said “read only”.
Problem solved, in case anyone else runs into the same difficulty.

tyvm. Properties worked for me!

Did you copy these documents from a CD-ROM disc?

It is a common issue to have files copied from a CD-ROM disc appear as read only once copied. This is because files on a CD-ROM disc are read only.

Either your document storage media is read only or the files themselves have been set to read only. Check file the file properties and see if the read only attribute is set on these files. If the storage media is the issue, such as an SD memory card set to read only then set it to write enabled.

Hi, thank you for your comment. That could very well have been the problem, so I will keep your explanation for future reference.

thank you very much