All versions of pwd protected .ods file return an error?

I doubt there is a fix for this but I have to ask before I give up on a very important document of mine.

I have many back-ups through time all the way back to when the document was created almost two years ago, about seven. I have tried the technique of changing the file to a zip and opening the content.xml file but since it is password protected the text was just gibberish and therefore I couldn’t locate the error. Then I tried the most recent version of libreoffice and a version from about two years ago on top of the version I had on my mac from last year on four different backups going back to the first backup I have.

All of them either, after I entered my password it produced no error but the app just kind of drifted off using about one percent of the cpu for 20 minutes when I ended it - or - they produced an “unknown read error” right after entering the password.

I can’t tell you how important this file is but I can’t figure out what is corrupted since I have tried many backups of the file and three versions of libreoffice??

wow… this community is terrible

@billboz better forgot your kind answer.

You can download all versions from Index of /libreoffice/old to test wich one can open your files, at some point some changes were on the password manager but I think oldest than two year, except of course if you haven’t the right password or files are damaged.

Thank you for that M.A.Riosv.
I will try an even older version. Its worth a try