Alt key no longer accesses main menu functions

I’m using libreOffice (and have used pretty well every version back to OO 2.0)
I’ve memorized a bunch of Alt-key combinations that allow me to work much faster. It involves pressing the Alt key with a key corresponding to a top menu , then another key to access an item in the menu list.
For example, I often combine Impress decks by going to the bottom of one, the pressing Alt-I, which opens the “Insert” menue. I then press F for “file.” It takes about .5 seconds to do this. Now I have to take my hand off the keyboard, go to the mouse, click insert and go down to F and click that. it takes about 3 seconds to do that.
Similarly, Alt-F, A to save as, Alt-I, N to insert a comment.
Now when I press the Alt key with a letter, nothing happens. This is a nuisance. I know that touch screens and colorful icons are the UI standard of the day, but I’m interested in getting work done, not playing with the toys.
I don’t see a way to regain this. I can’t record macros; apparently I’m supposed to load some Java run-time for that. One from Oracle is already installed and I have no idea where I would find a different one.
Very disappointed that important fuctionality is disappearing.

For me it is specifically the right Alt key that has become a problem. Left Alt on its own puts me in the Menu bar; Left-Alt-held-down plus character-key opens the specific menu (directly from the document, not going to Menu bar first). Right-Alt on its own also works, ie puts me in the Menu bar. The problem is Right-Alt-held-down plus character-key— the Right-Alt is ignored. FWIW I’m on Windows 7, using I think a US keyboard (but in Australia).

This is really annoying for touch-typists! Right-Alt works fine in everything else I use.

I am going to try using AutoHotKey to see if I can fool LO, but this will take some time and it would be great if it “just worked”.

BTW I just upgraded to LO and I don’t think the behaviour was present in 4.4.something that I was using previously— otherwise I would probably have complained

Confirming that the following AutoHotKey (dot-AHK) script has worked around the problem for me on Windows (sorry if the format of the lines below is messed up— I want line-breaks between them):

#IfWinActive ahk_class SALFRAME ; LibreOffice “class” at least for Impress


#IfWinActive ; ie only for LibreOffice, possibly only Impress

Both Alt keys are working as accelerators to activate the menus in LO 5.2 here, on Linux. There are some other functions they don’t work for as hotkeys, but it’s pretty easy to work around that.