Alt-TAB stopped working for LO Impress Mar. 7 2021

Alt-TAB (Cmd-TAB for the Mac) will usually switch applications windows, even when the app has maximized, for example running an Impress slide show.

Until the aforementioned date, when it stopped working for Windows 10 Impress only. I have a second, older laptop, which I updated and installed the latest LO ( I believe is the number). The old machine now matches my new ASUS TUF GAMING laptop as far as OS and LO versions are concerned. And the old one works just fine.

On my ASUS, when I put Impress into slide show mode, I lose the Alt-TAB functionality. This is the only app (I did not tests with other LO apps, though), PowerPoint, Firefox, Windows utilities, etc. all continue to be switchable with Alt-TAB only Impress fails.

Because of issues with the ASUS hardware, I’m forced to run Windows 10 ocassionaly, but prefer Linux. I have the ASUS configured for dual booting. The Alt-TAB continues to work just fine under Linux.

I presume there is some configuation setting that is preventing Impress from switching?

Any guidance on what to do to get Alt-TAB back?

Can’t confirm this on my on Windows 10 and in fact I don’t see any way to fix this by means of LibreOffice, since ALT+TAB is a shortcut of the window manager and not an application specific shortcut (You could try to disable Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering - but I have little hope that fixing your problem)

Hi Opaque,

As noted in the first paragraph of my post, I have a second laptop that works just fine, so I I don’t think you’d be able to reproduce this. :frowning:

What I was hoping was there might be a system configuration/registry option that might impact window switching.

I will look into Skia and see if that has any impact.


Well, disabling Skia did the trick for this laptop. Note that the second laptop has Skia enabled and it works fine. The difference is apparently the laptop hardware itself, getting in the way.

The failing laptop is an ASUS TUF GAMING with dual GPUs. The external HDMI monitor is handled by NVIDIA while the laptop screen run by an AMD Radeon RX Vega 10. Perhaps the full screen slide show of Impress is ending up on the NVIDIA somehow and the Alt-TAB only works for the AMD device? Regardless, this is in one sense fixed, in that I can do what I was doing before.

Alt+Tab is an operating system shortcut, LibreOffice cannot override it. Windows 20H2 added more complexity to this function.

In Windows, click Start menu > Settings > System > Multi-Tasking. There are several settings for what you see with Alt+Tab, you might need to add virtual desktops if that is how your system is set up. Cheers, Al

This is good to know but did not hava any effect on the problem. Thanks for your input.

As noted in my sescond comment to Opaque’s answer, disabling “Skia rendering” ‘fixed’ my immediate problem. I can now use Alt-TAB again.

However, this is just a bandaid covering a deeper problem. My ASUS, which has the problem, has dual GPUs. The Samsung, which works fine with Skia, has a single GPU.

Also as noted earlier, the ASUS GPUs are an NVIDIA for high performance use and an AMD Radeon for the laptop LCD. This configuration has caused problems for Linux. Initially, I installed Debian and graphics with it failed totally. I then found that Ubuntu would run on the AMD GPU but will no touch the NVIDIA. This means I have no external monitor support under Linux, so I’m forced to use Windows when I need that feature.

A real fix would be to figure out what is happening with Skia and the dual GPUs. I’d be happy to work with anyone able to do the development.