Always Opening .RTF files

I have saved a number of files in .RTF format. Whenever I try to open one of them in Writer 4.2, I get a message telling me that this is an executable file and asking whether I want to run it or display it. I am surprised to find that .RTF files are executable, but in any case I always want to display them. Is there some way that I can make Writer always choose to do so?

Supervision of opening executable files is a task done by the OS. Thus I recommend to look into settings of your OS.

I made some tests in LibO 4.3.6 but did not see such a behavior. (XP/SP3)

If you don’t find the solution could you up attach one of your rtf-file? Please note that this is a public forum, thus don’t have confidential information in an attached file.