(Answered) Comparing password-protected documents does nothing

In Writer, when I try to compare two versions of the same password-protected document (i.e. same password), nothing happens.

I open the first one, get prompted for the password, go to Edit → Track Changes → Compare Documents and choose the second version. I get prompted for the password again, I type it just like the first document. And then nothing happens. I wait for a couple of minutes, then second-guess myself and check word count on both documents.

The documents don’t contain the same amount of words nor characters, and they are of different sizes. Something should have happened.

I am currently using Version: (x64) but I’ve not had any luck with comparing password-protected documents in any version. I’ve only had need of this for password-protected documents since after version 6 was released, so I don’t know if it worked in previous versions.

Am I doing something wrong, or is this a bug? Is there a work-around?

So, I’m using Ubuntu 18.04 and LO and just tried this with the same results - it asks for the password and then does nothing (even though I specifically made the two files with slightly different text).
Looks like a bug. Checking the issue tracker just now I can find no entry however.

Would you like to open an issue on the bug tracking system?
(I can do so if you prefer, but if you do you will get notifications as the issue is worked)
Let me know if you prefer me to do so however.

BTW I just tested this with versions back to 5.4 and none of them work - asked on the QA channel at LO about this just now.

Turns out this an old bug and already had an issue opened for it, under the component Calc.
The issue has been updated to address all LibreOffice files and two test Writer files added.
If you have an account on the Issue Tracker system you can, if you so choose, add yourself to the CC field and get updates on any progress.

Until then the only work around I can think of is to save each of the files to a new file without password protection turned on.

The issue URL is: https://bugs.documentfoundation.org/show_bug.cgi?id=41544

Well - changing component wasn’t correct, since, as the bug description mentioned, Writer has own tdf#41493.

well, one of the folks on the QA irc channel thought it was good idea just to change to component LibreOffice since it is the same error in both Calc and Writer - but I do not mind walking the changes to the Calc specific issue back.

Thanks a lot for checking this on other versions - and for your very quick reply. And for looking into it. I’ll go add myself to CC.

I’ll copy+paste until it’s fixed.

OK, but you want to follow the issue posted by Mike above, as I’m reverting the one I touched back to the Calc component.

Also also - is there a button I press to have the topic answered, or is it enough to just change the title?

I’ll go to Mike’s link, thank you :slight_smile: