Any resolution to the default font bug?

I’ve just started using LibreOffice on a new Linux box (19.04 Ubuntu).

There seems to be a bug that I haven’t encountered before by which the font continuously changes to Liberation Sans and ignores both the default system font configured in options as well as any styles.

I’ve tried setting the default font to several different system fonts but text (particularly tables) keep sporadically changing to Liberations Sans.

This is pretty annoying.

Does anybody know a fix for this? Is it a known issue?

Can you characterise the circumstances under which this font change occurs? I assume you configured the default fonts in Tools>Options without style modifications, then:

  • starting with a fresh document, type text, save, reopen: any spurious change?
  • starting with a fresh document, change styles, type text, save, reopen, any changes?
  • using a previously saved document without style changes, change styles, … Any changes?

To be sure, do you save native (.odt) or foreign format (like .doc)?

I would recommend to create templates with desired fonts in desired styles and use the templates to create new documents. You can use TemplateChanger add-on by André Schnabel to quickly assign a template to an existing document thus changing its formatting (provided that, of course, you use styles and don’t use direct formatting). You can find a build compatible with LO 6.x here: (the build available at the extensions site is compatible only with LO 3.x).