Applications not displaying correctly on 4K display


I have just installed LibreOffice on my Windows 10 laptop and all of the applications aren’t displaying correctly (including the launcher).

See the attached image. I have a dark theme selected but the area of the menu bar on the left is a light colour. It’s present in all the themes.

I have tried installing both v7.0.5 and v7.1.2 and they both have this issue.

If I change my screen resolution to 1080p the problem goes away (this isn’t an option for day to day use though).

Does anyone know how I can resolve this?


If set, try to disable Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering and check whether that fixes/mitigates your problem

Thanks for the reply.

I had already tried that, but tried again. It didn’t make any difference.

I also tried toggling hardware acceleration on and off and OpenCL but they didn’t make any difference either.


Have you restarted LibreOffice for testing?

Yep, restarted, rebooted, uninstalled, reinstalled, all several times.

Not sure it would work since it’s a slightly different issue but who knows : [Solved] 4K Display Scaling/Blurry Screen Windows 10.

I had tried that but I had to set it to System, not Application, and it did remove the artefact but it made everything blurry. I have tried again and it doesn’t seem as blurry now, so I will keep it set like that.