Applying change of stylesheet doesn't work

I use ubuntu 13.10 and Libre Office both in english.

I have a word-document (.docx) which I want to edit in Libre Office Writer. The document comes with some stylesheets: I have “default” text with some quotes in between which are marked as “quotation”. When I open the document in LO and save it to odt, the quotations are still marked as “quotations”, the default text is still marked as “default”, allright.

Now I want to change the font of the document to garamond. So I downloaded a garamond font and installed it, and I’m able to use it in LO. When I change the font of the “default” stylesheet everything works as expected.
But when I want to change the style sheet of “quotation” it doesn’t work for each instance of “quotation” - some, but not every quotation is in Garamond, some stay the original font. Strangely the displayed font name (in thre dropdown menu between font size and the style) is “Garamond-Normal” (as defined in the style sheet of “quotation”) but the text is still formatted in the original font. Using “Clear Direct Formatting” shows no result. When I change the stylesheet-font to a different font (e.g. “Bitstream Charter”), the stylesheet works propperly and applies the change to every instance of “quotation”.
I have no idea how to solve this. Can you please help me?

Do you have AUTOUPDATE selected in the paragraph styles? Otherwise the style change will only be actioned when you add new text using that style. is now rather old. Do you have the same problems with 4.1 or 4.2? …Peter

Thank you Peter for your quick answer.
I updated LO to Version and selected Auto-Update (which was not selected before). The problem is still the same.

Another strange observation I made in the meanwhile: When I change the font-style to italic (for example), this is applied to the problematic quotations as well, only change of the font to Garamond doesn’t work. Whether the change of the font works depends on the font [!]. For example changing to Liberation Mono doesn’t work, changing to Bitstream Charter does work.

How about Linux Libertine G which is installed by default on LibO and very similar to Garamond. This might provide a bypass. I wonder if you have a problem in your installation of the Garamond font…Peter

Linux Libertine G is not installed with my LO version. At first I thought that it might be a problem of the installation of Garamond, too. But the fact that it doesn’t work with Liberation Mono which is preinstalled by default in LO is a counterindication to that.

I found and solved the problem by inspecting the content.xml of the odt-file. (I did so by saving the document as “flat XML” and opening it in a text editor)
The problematic quotations looked like this:
<text:p text:style-name="Quotations"><text:span text:style-name="BLABLABLA">This quote didn't work</text:span>

The unproblematic quotations looked like this:

<text:p text:style-name="Quotations"><text:span text:style-name="BLABLABLA"><text:span text:style-name="T10">This quotation was rightly formatted.</text:span>

Seems to me as if the author of the original .docx-file defined a stylesheet “BLABLABLA” manually and LO somehow had problems resolving the incorrectly nested span-definitions. Deleting the text:span text:style-name="BLABLABLA"> was the solution.

I still don’t see, why the problem depended upon the font, but somehow it works now.