APSO fails with Queue import error on LO BASE 6.4 and Win 10 64-bit

Alternative Python Script Organizer is published as compatible with LibreOffice 6.4, but it fails for me on Windows 10 64-bit and LO BASE 6.4. It works fine on my two Windows machines with LO Base 6.3. I’ve tried APSO 1.2.5 and the beta release. Both generate the same puzzling error message, beginning with "<class ‘ImportError’>: No module named ‘Queue’. A screen shot of the full error message is attached.APSO error.odt

If done multiple uninstalls and reinstalls. The error message makes me think I have my system somehow configured incorrectly because it is failing to import a python library. I’m seeing stuff on this error that might mean it is a problem between Python 2 and Python 3. For example python - no module named 'Queue' on windows - Stack Overflow. However, when I trace down that line to apso_utils.py, I find it is coded as:


import queue

except ImportError:

import Queue as queue

which is exactly how it is supposed to be coded for platform-independent applications. “import queue” is for Python 3, and “import Queue” is for Python 2. To throw this error it must not be finding either version of the queue module. Yet queue.py exists in the lib folder of the LibreOffice 6.4 folder tree, right where it should be.

Does anybody have any ideas about what is wrong with my configuration?

Work fine for me in Win 10, LibO 6.4 and APSO

I just tried it again, both with a user account and an admin account. Same result both times. The cryptic error message shown in the attachment appears as you install the extension in extension manager.