Arrow keys moving the documents instead of from cell to cell


The arrow keys suddenly are moving the whole document in Libreoffice Calc instead of moving from cell to cell.

I did some research and it looks related to Scroll Lock. I don’t have a Scroll Lock key on my laptop, so I am not sure what happened. I saw something about using xev to find a key to switch to Scroll Lock. I did that but I can’t see any change in Calc.

This is extremely annoying and slowing me down terrible because I have to use the mouse and click around instead of quickly moving from one cell to the other using the arrow keys.

I use Ubuntu 22.04 and LibreOffice Calc

Thanks for your help!

Hello @satellite,
This is not a Calc issue, but a hardware issue. Do a internet search including the laptop model.
Some possible answers: Fn+F11, Fn+S, Shift+F14.

Thanks @LeroyG ,

First of all, I would like to understand why Calc sometimes enters this mode where hitting the arrow keys moves the whole document instead of select one cell after the other. Does it have to do with the Scroll Lock?


Anyone could help me with this? ^^^^


Try with a virtual keyboard:

OK, thanks @LeroyG . Is it possible to disable this behaviour in Cal?


Yes. tdf#112876 is fixed in version 7.6. Since then, UseScrollLock may be used in Expert Configuration.