Assigned keyboard shortcuts do not work in calc


Recently I tried to assign a keyboard shortcut to open hyperlinks with the keyboard as using the mouse is tedious. I followed the normal rules and when to Tools > Customize > Keyboard tab, selected the keyboard shortcut (Ctrl+Return), clicked ‘Modify’ and saved it. Doesn’t work. I also tried to assign a shortcut for highlighting color but it doesn’t work either. I’ve also unchecked ‘Ctrl-click required to follow hypernlinks’ in Tools > Options > Libreoffice > Security > Security Options and Warnings > Options, but no change either way.

This should be straightforward but alas. I’d appreciate any help.

I’m using LibreOffice on Ubuntu 16.04.

Thanks in advance.

Ctrl+Enter is internally bound to Line Break, so I guess that won’t work.

I just tested assigning the function Open Hyperlink to Shift+F7 and that was successful.

The line break function is for when you’ve entered the cell in edit mode. So shouldn’t it work externally? Even so I just tried Shift+F7 and it doesn’t work.

For Open Hyperlink to be functional, first an hyperlink must be selected.

So, you will need to edit the cell (F2), select the hyperlink (Shift+Left Arrow), then use the shortcut key selected (or use the context menu to select Open Hyperlink).

Tested with LibreOffice (x86); OS: Windows 6.1.

Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.

If the answer helped you, you can mark the up arrow (Upvote mark) that is on the left (to vote, you need to have karma of at least 5).

That kinda defeats the purpose of using a shortcut, doesn’t it? It’s more work than using the mouse.
Also, I just noticed now that the hyperlink uses the format for Windows, though it doesn’t work on Windows either and using the mouse can still open it in Ubuntu.