At macOS - How do I fix the "Personal Settings Locked" message

Running macOS 10.15.2 LibreOffice Version: 6.3.4.2

When trying to open LibreOffice, Calc, Writer, etc, I get the following error message:

Either another instance of LibreOffice is accessing your personal settings or your personal settings are locked.
Simultaneous access can lead to inconsistencies in your personal settings. Before continuing, you should make sure user ‘christian’ closes LibreOffice on host ‘Christi7Sep2017’.

I deinstalled and reinstalled LibreOffice.

Cannot save documents in this case.

Other post says, delete the .lock file in the user profile in Windows.
Is this at Mac equal? Where do I find the user profile for Libre office?

greetings,

Christian

Hi folks, Im having the exact same problem. I see these wise posts below. However when I go to the Application Support folder, I have no LibreOffice folder! However Ive downloaded and installed it. Very bizzare. No idea where this .lock file is! (thats giving me the above error message.)

Any suggestions? I know I could just say Yes I want to continue. But Im a video editor and use some archaic software for some of my work, so dont really want to take the risk.

Okay, I solved it at my own way but if anyone has a solution without reinstalling: You are welcome.

I deinstalled it again and I also deleted the folder:

Press the keys: shift + command + G
Type in ~/Library/Application Support/

And delete the folder: LibreOffice

Then reinstall the newest version and this is it.

greetings, Christian

Deleting ~/Library/Application Support/LibreOffice did probably the trick, because it contains the user profile of LibreOffice on macOS, which probably had been corrupted. Re-installing LibreOffice won’t help in this case because it doesn’t touch user profiles.

Just to let you know, I got the same error and after reading this thread located ~/Library/Application Support/LibreOffice folder and deleted the file named .lock that I found there.
That did the trick :slight_smile: