Authentication prompt for email login when opening .docx

Shortly after opening a .docx file containing saved emails an “Authentication Required” prompt pops up asking for a user name and password for:

I can’t ascertain what this login refers to and why it is required. If the box is closed, it immediately reappears, and I am unable to save the file. Pressing ‘help’ follows a dead URL: file:///usr/share/libreoffice/help/en-GB/text/shared/05/err_html.html?System=UNIX&DbPAR=WRITER&HID=uui/ui/logindialog/grid1

Does anyone have any insight into what in the document might be triggerring this prompt and how it may be dissabled? I have checked the user has rw- permissions, and tried different settings under Security in Options (namely disable the master password, save/don’t save network connections).

Version info.

Do you mean E-mail addresses or some copy-pasted mail body text with some hyperlinks??

Can you upload a sample .docx file here?

Hi Zizi64, thanks for taking a look at this issue.

I mean copy-pasted mail body text with various hyperlinks (including mailto: email addresses etc.).

I was thinking there is likely some peculiar link in the document triggering the issue (the copy and paste was from an @aol address, which would explain the prompt message). The difficultly is that the file is very large, over 1,000 pages, and quite a mess of formatting and links so it is difficult to go through. Unfortunately I can’t share it as it contains confidential email information (this is a file of a relative who has asked me for help…).

Perhaps I should look to find a way to sanitise the entire document? I don’t think the owner needs any links working inside the document, only has been using it as a record of email correspondence.

Can you prepare a similar document with similar problem, but without confidental informations?

Not easily I’m afraid (if I knew what was causing the prompt, I would remove that element). Once I have access to my own system after the holidays I can install office and try to produce a minimal example, but I wouldn’t hold out for that.

I was hoping there would be information on what type of object can produce this prompt, or how it can be dismissed or overridden in some way. Do you know what it is trying to do here, connect to a mail server?

I don’t practice DOCX encoding but the sole explanation for such a behaviour is a functional URI inserted in the document and Word tries to retrieve data from this URI.

Have you tried to switch off your network connection and see what happens? Do you get a time-out (unable to connect to server) or still an authentication request?
Or perhaps Word will use a cached contents.
Have a try.

For some reason the version information was cut from my original post:

Version: / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Ubuntu package version: 1:7.3.7-0ubuntu0.22.04.1

I have now tried this: without an internet connection the prompt does not appear and the file can be saved as normal.

Is there a way to prevent libreoffice from trying to access the internet / resolve URIs, or possibly disable URIs on a file-by-file basis?

Without any idea on the contents (encoding of the email citation), it is hard to tell. In addition, you start from a .docx which is an alien format needing conversion). Now that you can work, you may try to extract a minimal content with a single email reference causing the login authentication request. Perhaps, this reduced problem file is “public” enough to be diagnosed by contributors here, eventually being sent through private mail.

I had some luck with this - going through the document (now I can open it) I quickly noticed several elements with the same “apis.mail…” type URI. These appear to be some image URI that was embedded in the original email.

I copied one of these into the attached document. Trying to open to open it gives the same authentication prompt, but only once, which makes me realise with the original document that a prompt is generated for each troublesome element and indeed if you click ‘Cancel’ with that document enough times you can eventually edit it.

test.docx (5.0 KB)

Never paste such content (nor a preformatted text) from a foreign source into your documents. Use the paste special - Unformatted text option.
And use the native ODF file formats for your important documents.

Thanks, I’ve already advised them to this effect. That being said, I hardly think you can blame a novice user for using the default Copy+Paste behaviour (and then being confused by a seemingly unrelated prompt with a missing help page).

It was not a “blame a novice”. It is a base information for the future working - if you want to work with the LO more efficiently.

Strange behaviour: when I hit Cancel in the authentication prompt, it takes awfully long before an outline for the image appears. The same delay occurs if I inadvertantly cause a refresh.

Taht said, I can’t give any clue about DOCX. Your document is converted by Writer to LO internal format which changes the tracks to handle the issue.

From a “philosophical” point of view, LO is rather intended for “offline” documents (textn spreadsheet, presentation) rather than “live” “online” ones. This is an approach diferent from HTLM browsers like Firefox. Consequently, you should avoid inserting “live” elements, i.e. hyperlinks pointing to the world-wide web. Hyperlinks for contents replacement are perfectly acceptable for local targets (within same document or computer). Otherwise, either consider hyperlinks should be explicitly control-clicked by user to become active or are “quotations” for the real location of the associated data, i.e. a textual not-active link.

You would then avoid many problems.

@piperfw, this is not a solution to your question.

Since you have already posted this information as a comment (thanks!), please delete this non-answer. Thanks.

Hi, yes sorry hopefully it has been removed now.