Autocalculate not performing in expected manner

Bug has been reported by others but closed without fix. It is still present on v (flatpak running on ubuntu)
It is easy to generate the bug and I have seen it in multiple sheets over the last few versions of LibreCalc. The way to easily make the bug is create a formula. Then ctrl-D on the cell below. the copied formula will not update when a variable is changed. The original formula will however auto-recalculate fine.

Turning off multithreading calculations did not affect the bug. My only workaround is to hit f9 every time which is surprising. Before I noticed the bug I would have incorrect values in the spreadsheet. I think this is a dangerous bug for cases where someone relies on the results for critical decision making or analysis.

Bug has been reported by others but closed without fix.

Which bug report number? All of the bug reports related to this bug have been closed, because they are duplicates of #tdf137248 (and reporters obviously did not thoroughly check, whether the bug they are about to report, has already been reported). Bug #tdf137248 has been (verified) fixed and fix will be available in version 7.0.3.

Thank you. I see your point about the bug reports. Excited to get 7.0.3 for the fix.

You should set a check mark at menu Data>Calculate>AutoCalculate.

hello @m-matt,

in order of probability:

  1. as you ask about ver. there is! a fresh bug causing such behaviour, ~15 reports in bugs, no need to inject more duplictes.
  • solution: use another version. imho 7.1 (still alpha) and 7.0.1 are not affected, a fix is announced for 7.3, or use ‘F9’ (for single and all ‘volatile’ cells) or ‘shift-ctrl-F9’ for the whole sheet,
  1. most common fail, unlikely since you are quite familiar with the program, but it often happens with other users: ‘autocalculate off’ as @Hrbrgr assumes
  • solution: check and switch on if necessary,
  1. very rare but happens: all versions after version have bugs with autocalculate, this sometimes simply stops for some cells (all versions i have tested, i guess the others too). The problem is addressed, most of the reproducible errors are solved, most of them were caused by shared formulas (introduced with ver. 4.2?), new problems were added by ‘threaded’ and ‘openCL’, old problems got worse or obvious. What’s ‘left’ now undermines calc’s reliability, but is difficult to correct because it is sporadic and mostly not ‘reproducible’.
  • solution: Versions prior to 4.2 (no joke, i would do it, but it’s ‘eye powder’ on my 4k screen), disable openCL and threading (doesn’t help against everything), use crtl-shift-F9 (stupid if you forget).

new idea … disable shared formulas (to produce such ideas i write here and think about it instead of just commenting “use google or a better search engine and search the web, search in ‘ask’ and ‘bugs’, you will find many solutions”). For ‘parallelization’ sometimes you could set a threshold in the advanced options, i’d like to know if there is similar for shared formulas, if not it would be a suggestion for improvement until the problem is solved differently. If there is no ‘official’ possibility … empty lines (every second) could suppress the problem?, i’d try but have to use it some time to see if it’s different, unfortunately with rare sporadic errors you only know after a long time if an action is useful and you never know if the problem is gone for good … and of course there should be a performance impact??, but you have to accept it for reliable results?? with my first tries i couldn’t spot any significant difference in performance with empty rows inserted …



P.S. ‘solved marks’ and ‘likes’ welcome,
click the grey circled hook - ✓ - top left to the answer to turn it green if the problem is solved,
click the “^” above it if you ‘like’ the answer,
“v” if you don’t,
do not! use ‘answer’ to add info to your question, either edit the question or add a comment,
‘answer’ only if you found a solution yourself …