AutoCorrect numbered list adds a 0

When I want to start a numbered list in Writer, it’s easiest to type the number, followed by a period or parenthesis, type the first line, and hit Enter. AutoCorrect automatically creates a numbered list, but it adds a 0 to the number typed:

  1. fsgfsg
  2. fsfdg
  3. fdsgfg

Using F12 or toggling “Ordered List” works fine. Can I get it to stop adding the 0 myself, or is this a bug that needs to be fixed?

Also, I noticed issues trying to use i. and a. to start a ordered list, but I don’t have too many details right now.

I would recommend using styles to create numbered lists. These direct formatted lists can cause problems but not this sort.

It is a recent bug, it doesn’t exist in nor Can you create a bug report? See How to Report Bugs in LibreOffice - The Document Foundation Wiki

The only way to offset the starting number in a list is to play with settings in Format>Bullets & Numbering, but this modification is not persistent and the setting is reset as soon as you leave the list.

By the way, you didn’t mention OS name, LO version and save format. Does this occur after a recent update? If you’re under Windows, try to reset your user profile.

Offset doesn’t affect this. I think it’s a bug based on the other comment.

OS is Windows 11, LO version is, not sure what you mean by “save format”. It does occur after a recent update, but I hadn’t used LO in a while (especially not to create lists) so not sure how recent of an issue this is. I can try resetting user profile.

Bug posted
Bug 153423 - Formatting: AutoCorrect numbered lists incorrectly starts list with 10
Consider using list styles from the Sidebar or from Formatting (Styles) toolbar instead. If you insist on direct formatting then the Standard toolbar icon for numbered lists works correctly. Cheers, Al

[Edit 2023-05-24]
Bug fix applied 2023-02-09 in 7.5.1, also in Master