Autocorrect while typing not working

In prior versions of LO Writer I could set Autocorrect to convert “b/c” to “because,” for example, but now it won’t work, or something else is preventing it. Can you help me fix it?

Tools/Autocorrect/While Typing - enabled.
Tools/Autocorrect/Autocorrect options, Replace Tab line for the above substitution - confirmed.

I’m on, Windows 10 Pro

Works for me on, Windows 10 Pro. May be an issue with your LibreOffice user profile and reset to factory settings may help.

When you added your auto correct was the language drop down box showing the same language as the default for your documents?

The default for my documents is English UK but when I open the auto correct options the initial language I see is English NZ, I have to change the language to English UK for any alterations or additions to have effect in my documents. Cheers, Al

Ps I always know because English NZ auto correct is completely empty so it it’s easier for me to notice

Ensure that you add your AutoCorrect entry to the same language as you expect to use it in. In the shown case, the new :setting: AutoCorrect entry will not work in the current document due to a language mismatch. Cheers, Al