Autofilled equations not working

My Calc recently crashed while working on my budget spreadsheet. When I reloaded it, it had stopped working in a really weird way. Any equations that I autofilled by click-and-drag simply didn’t work. The equation was right there, all correct, but the answer was always zero (even if the equation was something very simple like =SUM(C1:C22).) But (and here’s the super weird thing), if I went into the individual cell, deleted one character, retyped it, and then hit enter - it works! The equation is exactly the same, but it only works when I’ve individually typed it.

There are tens of thousands of cells in my sheet; I can’t possibly retype every equation. I’ve tried closing the file, turning off the computer, turning everything on again: the same problem persists.

Can anyone help?!

  • Which LibreOffice version ?
  • Which operating system ?
  • Did you try to open your file while running in LibreOffice’s Safe Mode (Help -> Restart in Safe Mode... and using File -> Open to open your file in safe mode)? If not, try this procedure (take care to click button Continue in Safe Mode to really reach safe mode) and tell about the result of this test (i.e. does the problem exist in Safe Mode as well)

Maybe Menu/Data/Calculate/Autocalculate it’s disable.

Thank you - this worked! I don’t know how that got toggled off. You’re a star.