Autofilter menu disappears as I move the pointer

I’m using Ubuntu 18.04 on a MacBook Pro retina 13" and LO installed via Synaptic Package Manager; when I apply AutoFilter in Calc, as I move the pointer to select something inside the AutoFilter menu, the menu disappears. If I press again the AutoFilter triangle icon, the menu appears again, but as I move the cursor, it disappears.
I tried to install also LO via snap in Ubuntu Software, but I have got the same behaviour.
I’ve just noticed that with the live distro of ubuntu 18.04 on my MacBook Pro, AutoFilter menus work fine, so I’ve completely removed and reinstall LO via Synaptic Package Manager, but the problem still persists.
Can somebody help me?

I see the exact same behaviour on two fresh Ubuntu 18.04 installations (Version: and Very frustrating.

So, I entered a bugzilla with your text (please add any further observations here: “”. I hope the developer team can nail this regression error soon.

I also discoverd a work-around: Right click on the triangele icon and select “Selection List”, then the menu stay open. That can work for now. I believe it is a Linux only error based on the feedback.

Same on Debian 11 bullseye, LibreOffice version autofilter menu disappears immediately after moving a cursor.

Thank you for the workaround: workarounds are foundation of Linux software :wink:

This is a bug reported in Bug 122084 that affects users with HiDPI screens that use screen scaling.

This workaround worked for me :

Right click on the triangle icon and select “Selection List”, then the menu stay open.