Autoformat - writer/calc - missing something?

I have set up a calendar in writer that uses a table for the body of the calendar. Good so far. I can then format the table to fix the row size, assign background colours, borders etc… Again fine. I have also then set up styles for each month (a page style) and for ‘red letter days’ and previous/next month’s days.
What I then wanted to do was to set up a style for the table itself, so that the days are automatically given the same background colour, font, font effect etc - then making it very simple to change the appearance of the calendar.
I thought that ‘Autoformat’ would then do that for me, bit I seem to be having a problem. I set up a table with 7 columns, starting with Monday and finishing on the right with Sat/Sun. The heading row is given a background colour of Grey 10%, and the body of the table a background of light green, with the two weekend columns being given backgrounds of light blue. Again all fine so far.
However, if I click on a cell in the table and then do a Table-Autoformat-Add and specify my name for the format (Calendar), it save it, but changes the format. The header colour and main body colours are both preserved ok, but instead of saving the two weekend columns as a separately coloured block, it only saves one column. Also the row height does not appear to be preserved.

Is there something that I’m missing or does autoformat only cater for top row, first column, last column, bottom row type settings? And is there a way of preserving the set row height/column widths as well? All the check boxes in the autoformat creation screen are checked.

Yes, AutoFormats don’t know more than one rightmost column.
For Calc, row height and column width are (naturally) not cell attributes, things may be different for Writer tables’ AutoFormat.