"Automatic" + "System theme" should set "Document colour" to theme colours

As libreoffice - Libre Office Calc - Dark Modes Aren't so Dark - Unix & Linux Stack Exchange describes, #Calc displays the cells as white regardless of my system theme:


You are referring to a two years old thread. Are you using an old version of Calc? (You didn’t mention OS/Desktop/LO-version.) In this area were a lot of changes during 7.5 and early 7.6 versions.

1 Like

No, @Wanderer, as the presence of certain functionality in https://ask.libreoffice.org/uploads/asklibo/original/3X/2/e/2ed20b8a0340e9f1bfe75652cf00b68951b07f5b.png demonstrates. I’m using:

Version: (X86_64) / LibreOffice Community
Build ID: 60(Build:1)

…more specifically, https://download.opensuse.org/repositories/openSUSE:/Factory/standard/x86_64/libreoffice-

Maybe, this applies, try with 24.2, first week of February:

  • Automatically switching to dark app colors and a dark icon theme when a dark color scheme is configured in the desktop settings now also works for the Qt-based UI variants used e.g. by default on KDE Plasma. tdf#156894 tdf#149611 (Michael Weghorn)
1 Like

@EarnestAl, 156894 – kf5/qt6: Dark system themes don't automatically enable corresponding dark icon themes hasn’t applied to me for some time, but in case you didn’t notice, I’m actually the reporter of 149611 – Page color doesn't adhere to dark theme (kf5)… I had forgotten I’d reported it though, so thanks - I’ve commented 149611 – Page color doesn't adhere to dark theme (kf5).

As 149611 – Page color doesn't adhere to dark theme (kf5) describes, using

Version: (X86_64) / LibreOffice Community
Build ID: a8c9976b9f74750b38aab69bdb81f0722231d164

from sudo snap install libreoffice --channel=latest/beta at least displays the page using the (presumably default Adwaita) dark theme colours:

This isn’t perfect, but it’s better. Consequently, I’ve filed 159303 – Document Dark Mode doesn't reflect system colouration..