Automatically inserted pages missing

I’m laying out a book, and I want the chapters to begin on the right. I have created a page style for chapter fronts and set it to only be right pages. LibreOffice is correctly making the chapter front odd-numbered pages, even when that means skipping a page number. (I’m trying to make everything work before I go through the whole book and apply styles, so I only have two chapter fronts so far, one of which is the first page because I haven’t inserted the title pages and such yet.)

But when I export a PDF, instead of a blank page 4, I get no page 4 at all. So while the page number at the bottom of the chapter front says “5,” it’s actually page 4 of the PDF.

I have gone to Options: Writer: Print and selected “print automatically inserted blank pages.” It doesn’t help – and it keeps un-checking itself. (Yes, I am closing the dialog box by clicking the OK button.)

Is there anything else I should be doing to make this work automatically, or am I going to have to resort to inserting the blank pages manually?

Thank you!

You need to set that not on the printer properties, but on the PDF export properties. Go to File → Export as PDF and under “General” check the option “Export automatically inserted blank pages”.

That works. Thank you!

@arc - please click the “checkmark” symbol to the upper-left of this answer. That’s what signals to other users that the question has an accepted solution. Thanks.