Autotext not working (Display remainder of name as suggestion .... not showing)

My Autotext is not working anymore. The “Help Tip” when I check the “Display remainder of name as suggestion while typing” is not showing anymore. I used to just press “Ctrl+Tab” to advance through the my many autotext entries. I cannot do this now.

I have reinstalled Libreoffice. I have reset my profile. Copied another profile from another installation. I have checked the language and path settings. I have also used the portable version of libreoffice. Nothing worked.

If it matters, I recently tried and experimented with different standalone “text expanders” like Lintalist, Espanso, Autotext and Beeftext. Did it affect my libreoffice settings?

However, the “Help Tips” shows up in OpenOffice.

Also Autotext is working when I use the shortcut+F3.

I am on Windows 11. Libreoffice (64)

Thank you.

Have you enabled Word Completion in Tools > AutoCorrect > AutoCorrect Options > Word Completion?

It is possible that programs that intercept the keyboard might prevent word Completion from working, for example, Word Completion isn’t activated by pasting the first three letters of a word.

Or it isn’t activated by Windows 11 Touch Keyboard (virtual on screen) but does work with the other Windows 11 virtual keyboard, On-Screen keyboard

I think you mix “autocompletion” and AutoText in your question. AutoText has always been activated by F3.

Autocompletion is a different thing. After some necessary “warm up” time, Writer has accumulated enough typing statistics about your document and can then suggest “words” based on the currently typed prefix.

If you’re starting a new session or a new document, the statistics table is empty and therefore autocompletion will not yet work.

Thank for the reply. Yes, I have done this. I was thinking at first that Autotext and Autocorrection are somewhat interlinked. But my Autocorrection is doing fine. I only have a problem with Autotext and only insofar as I cannot anymore cycle between the “Help Tip” when I check the “Display remainder of name as suggestion while typing.”

Blockquote I think you mix “autocompletion” and AutoText in your question. AutoText has always been activated by F3.> Blockquote

Thats the thing. I can activate my Autotext with F3, but I cannot cycle with my several autotext entries using “Ctrl+Tab” and “Ctrl+Shift+Tab” because the “Yellow Help Tip” prompt does not appear even if I enable the “Display remainder of name as suggestion while typing.”

Since the shortcut to your AutoText entry is not kept in your document (the shortcut is replaced by what it stands for), the shortcut is not a document “word” and is not entered into the typing stats table. It is not reachable by autocompletion.

Thank you for taking the time to explain but I am not “reaching” for autocompletion. I used to have a “yellow Help Tip” when I enter at least three characters for my autotext. It is not there anymore.

Please test if Menu/Tools/Options/LIbreOffice/Genera - Extended Tips, can help.

1 Like

Thank you, but it did not work.

I just realized that this is not a hardware issue because Openoffice installed in the same system is working.

I also live booted on MX Linux, taking a cue from ajlittoz:

If this is a Window$ issue, I can’t help you. I’m under Linux. >

and it is working fine.

I think I now understand your problem. When upgrading, the Windows installer has the bad habit of resetting your user profile (or it is recommended to reset it to avoid nasty issues).

  1. Go to Tools>AutoText
  2. Check Display remainder of name as suggestion while typing
  3. Close

This should fix it.

Done this already. Thats my problem. It is already enabled but the yellow “Help Tip” is not showing.

  1. Already checked the directory path and the Language settings (English USA).
  2. Reinstalled Libre.
  3. Used Portable Libre.
  4. Used Safe Mode.
  5. Tried resetting the User Profile.
  6. Transferred a working profile from another installation (Windows 10, same Libre version,

Nothing worked.

Curiously, OpenOffice is working just fine. It is showing the “Help Tip.”

Procedure 6. is not recommended as somme components of the user profile may be very closely linked to internal structures. If you transfer between same x.y, it should be OK, though.

Have you cold rebooted since your last upgrade?

Yes. Done this many times already. Been trying to figure this out since yesterday. Maybe this is a Windows 11 issue? Because my other installation in windows 10 is working just fine.

If this is a Window$ issue, I can’t help you. I’m under Linux.

Its ok. Thank you for your time.

Is Windows 11 in tablet mode, that is, no keyboard attached and using touch screen keyboard?
Apparently tooltips don’t work in tablet mode, see html - How do I make tooltips work on Webapp when running on tablet - Stack Overflow

Nope. Not in tablet mode. This is a desktop with an attached keyboard.

I just experimented with Libre Portable:

6.4.7 working
7.0.6 working
7.1.8 working
7.2.7 not working
7.3.5 not working

This is probably a bug, right?

Might be a bug, see:

You could try and see if in Tools > Options > View changing the Graphic Output settings to Force Skia software rendering fixes it or unticking Use Skia for all rendering helps

1 Like

Skia settings did not help also, but thank you for your time. I will try to report this as a bug.