axes got garbled in upgrade to 6.0.7

I just upgraded from Version 5.3.6 to 6.0.7, and in the process, the x and y axes of one of my charts got screwed up, and I’d appreciate help fixing it.

Previously, the Y axis was manually set to range from -2% to + 24%, which was what I needed to display the data ranges. All of the source data is in X.XX% format, and the chart displays 5 different ranges as lines. The x axis was set up as a text source data, with the labels being text representing workdays during the month (excluding weekends, so the text string for the first part of February runs 2/1. 2/4, 2/5, 2/6, 2/7, 2/8, 2/11. . . . . .)

In the new version, both axes are bolluxed.
The Y axis is displaying .0%, 1.0, 2.0, 3.0 …9.0 – no percent signs, no 2nd digit to the right of the decimal point and, most peculiarly, not displaying anything above 9.0. The top half of the scale has no labels at all
The X axis is truncating the labels – 2/1 through 2/8 are ok, but everything from 2/11 through 2/19 is displayed as only “2/1”, and everything from 2/20 - 2/28 is displayed as only “2/2”.
I’ve tried changing font sizes, number formats, scaling, and nothing seems to get me back to where I was in the prior version.

Any thoughts, suggestions or insights would be greatly appreciated.

Thank you all.

You say I’ve tried changing font sizes, number formats, scaling, and nothing seems to get me back to where I was in the prior version

Your problem might be due to something hidden (non-printing) in that particular chart, or to a bug in v6.0.7, or the result of both. If it is something hidden, try re-creating the chart from scratch. In addition, if you upgrade to v6.1.5, the current stable version, you might find that the bug has been fixed and that you can now successfully adjust the chart to what you need. I hope this helps.

Thanks, ve3oat.
I upgraded to version yesterday, and that seems to have solved the issue with regard to the Y axis, but not with the x.

For the X, I’m suspecting it’s a not-yet-addressed bug: as you suggested, I created a new chart – initially, using a small (20 data points on one line) subset of the original data, using the corresponding 20 points of date info as the X axis, and it displays just fine – either when I link the axis format to the data’s format, or when I specify the format within the axis format screen. BUT, when I expand the data to include, say, everything YTD (40 data points), then it starts truncating the text labels in the X axis as noted above. it’s almost as though the “scaling” of the x axis isn’t fully functional – is there a way to, say, display every other (or every third) label on the chart, and thereby work around the truncation? (I tried deleting every other item in the x axis series, but the remaining items are still shown as truncated labels along that axis)

The Y axis issue was the bigger one for me, and I can live with this until the bug is addressed. Is there anything more to do to present this issue clearly to the coding mavens?


Glad the upgrade helped.

Like you, I too have experienced the truncation problem along the x-axis, but have not found a way to skip labels and display only every second or fifth or tenth one in order to save space on an otherwise crowded axis. The facility might exist; I just couldn’t find it. (It would be a nice enhancement.)

I understand that, although some coding mavens do read this forum, the best way to get the attention of the LO developers is to report the bug in detail at