base crashes when opening sqlite db view

I have an ODBC connection to a sqlite db. For some or other reason, although base opens the database itself, when I try and access any of the tables, base just closes quietly/ crashes. I have done an integrity check via SqliteStudio and apparently there are no problems with the Sqlite db. I can also add/ amend etc to the tables via SqliteStudio, but need to use base to create reports. (This db was initially an embedded database within base, which I managed to “convert” and now have a need to recreate my old reports…)
Is anyone else experiencing this issue? Is there a fix?

**OS: Linux Mint 17 & Libreoffice

Have you tried using JDBC? Thinking maybe SQLiteStudio connects natively to the DB and that’s why you don’t have a problem.

No, I’m trying to avoid Java at all costs. I’ve had so many problems with the embedded database that I would prefer not to have the number crunching machine running in the background. All I have read states that it should work, and it worked the first time I accessed it, thereafter LibreOffice crashed. I have just tried Open Office and I get the same result…
Anyhow, I don’t know enough but a JDBC connection to get it going… will it connect an SQLite database?