Base crashes when running query using ODBC/Oracle

I created a Base file and set up a couple of queries to my Oracle database weeks ago. These early queries are still there, and they still work. When I tried to create new queries, the application crashes. The files are successfully recovered (all they contain are queries), but I still can’t create new queries without an application crash.

I can’t supply a Base file to this forum for testing, since my Oracle server is inaccessible to the internet.

Can you run libreoffice in a terminal and copy all messages into your post please? It should contain reasons for the crash.

This might be another thing I need help with as I have not tried running LibreOffice in Terminal before. I launched this command:


LibreOffice opened. I went through the process of recovering my Base file, then opening it, running the query, crashing, recovering, opening the file, and then quitting the app, but at the end of all that there was no output in the Terminal.

I imagine there is probably a flag I should use at the end of the command that I do not know about?

However, please upload your .odb file as your question relates to the inability to add queries.