BASE error: The database is already in use by another process

This entire episode is frustrating. Hopefully some kind person will have a solution for this.

First, there seems to be no way to import an entire spreadsheet and have it make each tab into its own table. (Okay, whatever.)

Second, after copy and pasting 20 tables manually into BASE, I save it then immediately go to save it again with another name (for redundancy / backups). It gave a quick error about connecting to (the original name) database, and the whole thing crashes. (Why would it need to connect to anything? I manually entered everything in!?)

Third, upon re-opening it won’t open either file. The original file gives an error that says “The database is already in use by another process” and the new-name file says “The driver class ‘’ could not be loaded.”

What in the world happened? All I did was save the file (successfully?) and then ATTEMPT to save it under a new name. Why EVER would this not only break LO Base, but also break both files??

Fourth, searching for an answer in these forums has been futile. Many people have asked the same question. No real answers have been posted (that I saw).

PLEASE, does anyone know how to get my data back? And if I have to spend a half-hour re-doing it all, what guarantee (lol) is there that the same thing won’t happen again? What I mean is, I didn’t think it should have broke at all. (???) Other people have also had this problem so I’m concerned enough to post here before just re-doing it all.

BTW, I last updated LO a month or so ago. It’s v running on Windows.

Thank you!


I have no problem with LO v7.1.4.2 on Win 10 with HSQLDB embedded (you fail to note your database). Just did one table but don’t see any reason to go further. Possibly try resetting your user profile → LibreOffice user profile

You stated many have asked this & other people have had this problem but you provided no links to those.

Ratslinger, thanks for the reply! I’ve seen your name on several of the other threads. I will answer your questions.

First I’d like to say that I REALLY appreciate your time and help with this. I’ve used LO for many years (TY LO, great program!) and used Access and Base a number of times, years ago. Never had this particular problem.

Here are some links, as requested:

All these seem to point to Ubuntu as the root problem. I’m unfamiliar with the term PPA, though I googled “libre office ppa” and answers all seem to refer to Ubuntu. (con’t)


Ratslinger, you mentioned “you fail to note your database.” I’m sorry, I don’t know what you mean. I’m sure the name of my DB is not germane to the problem. (The first name was LOG1 and the second name was AP1_DB2, both w/ auto ext .odb).

Some have suggested locating the temp lock file and deleting it. Is this an option I should try? Do you have any idea where to START looking for this file? (I typically see temp files for Writer and Calc in the same folder as any orig file, but do not see it in this case.)

Weird quirk, the error message lists a drive that is not even in use! From the error code “The database is already in use by another process: lockFile: org.hsqldb.persist.LockFile@4cc1321[file =F:” Well I don’t even have a drive F right now. Nothing was plugged in (no extra drives etc) during the time I made this DB last night. AT NO TIME was drive F active, only C. I double checked when I first got the error, and I did it all in one sitting so no way I “forgot.”


(final continuation)

Maybe it just had a hiccup. I can live with that answer. But if you have any idea how I can keep this from happening again, I can just re-do the work. The links posted above indicate that the problem happens randomly and without warning, on DBs that previously worked fine. This is the real reason for my help request. Do you have any idea what I did to break it, so I can avoid that in the future? I don’t think I did anything unusual at the time. All I did was save and then save again immediately with a new (redundant) name.

Alright, a couple updates.

Turning on “file options / show hidden files” did the trick. Only the (new name) DB shows a temp file. But that is the one that gives the error “Driver class could not be loaded.”

I did a global search for my original DB (because it’s strangely MIA) and it shows up with a lot of variations under “C:\Users\owner\AppData\Roaming\LibreOffice\4\user\backup”

I apologize for the WORD SALAD. I hope this info helps identify the problem. TYTYTY!


The links you provided are relater to the Linux distro versions of LO. That was noted as a problem and loading a version from a different source fixed the problems. Windows versions do not have this source problem.

Failed to note database is not the name of anything. It is actually the database you are using. Like Access, Base is only a front end to a database. Many different databases can be used. My test used one of the Base supplied databases - HSQLDB embedded.

For locked files se:

If a locked file is not the issue, try resetting the user profile as noted in my first comment.

TY for the quick reply. It all seems so quirky so I tried re-doing a new DB, saving every two tables (lol). Everything seems fine with the new try. How strange.

Yes, I noticed that all previous instances of this problem were associated with Ubuntu, which is weird because I’m using Windows (7) on this machine.

I guess it was just a hiccup. But I’m slightly concerned with the other posts which mentioned the problem coming out of the blue on previously working DBs.

I sure would like to know why this happened - but only from a techie-curiosity POV. In that vein I am making sure to let you know the conclusion of this matter. I have a (new) working DB now so I guess all is good. Just letting you know because you seem to be the resident Tech here, and it’s always good to get trial/error info.

I will fill in the answer box as solved.

Thanks again for your help here, and in all the other threads where people forget to say THANKS!

TY for the tip about these interfaces being fronts for SQL. I picked up on that but my experience is limited to a bit of fooling around with phpmyadmin. There’s so much to learn here.


Thank you for the information. Please know, there are many knowledgeable people here answering questions in all categories including Base.

The resolution of this matter is that it was some kind of hiccup. After receiving support to build my confidence that it wouldn’t happen again, I re-built the DB (saving every two tables lol). All the tables are in and it works fine. I even saved it under a new redundant name (without incident this time).

So it was some kind of hiccup. The original DBs are still problematic but I can delete those since I have the new (re-made) one which seems to work fine.

In light of other threads of this nature which indicated that the problem came out of the blue on a previously working DB, I will be sure to save a FEW different filenames for this DB.

I tried to mark this as SOLVED but it said I needed “points” to do that. (???)

Not necessary. Will be changing facilities in another month.