Base form wizard can not save form (

Created table then tried to create form using form wizard using all table fields except ID field. Got through all the specifications doing Next and got to least page which is Set Name. I selected a the name ContactDetail and clicked Finish. Nothing happens. Page stays up. Back, Finish, and Cancel buttons enabled. No error message. Tried several times with different names (Contact_Detail, Contact) and same results.

LibraOffice on Xubuntu 20.04 using HSQLDB database. Image below:


On Ubuntu 20.04 with LO from TDF with HSQLDB embedded, had no problems. Tried best as possible to duplicate your table (confusing comment about ID - except ID but it is on form). Created form with & without ID.

May want to try resetting the user profile → LibreOffice user profile

Yes the ID was not intended but doing this again I discovered that if I selected all the fields of the table except the first one (wihich is ID (primary key)) then use the “>>” to move the fields to the selected fields box, the first field (ID) comes with it. I had to put the ID field back to the un-selected list before dong “Next”. Result is the same. When I get to the end of the Wizard “Finish” does not do anything I can tell with either specifying working with the form or editing the form. Also no error message that I can see. It seems I can not add an image in a comment but the form looks like the original but without the ID field.


As my comment states it mattered not whether the ID was included. You did not state if you reset the user profile. You might also want to try and create a form in design view. If you have and nothing changed, then it is probably best to file a report here → Bugzilla.

I am having the same issue in Kubuntu 20.04. I have tried several different forms based on different tables and nothing seems to get me a form created. At the end it just moves the Focus to Cancel.


If you read my comments I am not having this problem (just tested again).

Comments also stated to try resetting user profile & if that doesn’t work submit a bug report.

I have the same issue with stock LO Base installed from Ubuntu Software. I also had install: libreoffice-sdbc-hsqldb, so I suspect that there is some other package missing from the default installation.
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded