Base - no sdbc-firebird driver for LO 6 on Ubuntu 16.04?


I’m running Linux Mint 18.3, 64bit, mate

Earlier I had installed LO from the LO website (Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft). In that version, Base uses firebird as embedded database.
Because of stability issues, i re-installed LO 6.2, this time from the PPA (

In this PPA version of LO, the only embedded database in the list is HSQLDB, no Firebird. I can still open the odb files that I had previously created in the downloaded version of LO 6.2, but I can’t open forms or see tables because "The connection to the datasource could not be established, No SDBC driver was found for the URL sdbc:embedded:firebird’.

So it seems the sdbc drivers for firebird are missing.

I tried installing libreoffice-sdbc-firebird from the Linux Mint software manager, but that gives the error ‘Depends: libreoffice-core (=1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.2.8~rc2-0ubuntu0.16.04.1 is to be installed’.

So it seems I need sdbc-firebird drivers that are specific to LO 6.2, but I can’t find those. A google search gives me these hits: Libreoffice-sdbc-firebird Download (DEB) and Ubuntu – Package Search Results -- libreoffice-sdbc-firebird , but they don’t have sdbc-firebird drivers for LO 6.2 for Ubuntu 16.04, only for later versions of Ubuntu (Linux Mint 18.3 is based on Ubuntu 16.04). Still, the drivers must exist somewhere, otherwise the LO version I downloaded from the LO website wouldn’t have worked with firebird.

Based on other posts I took following steps:

  • I removed my user profile and made a new one, but that had no effect.
  • I also doublechecked the java settings: tools > options > LibreOffice > advanced > "Use a java runtime environment" is checked, the installed JRE is “private build 1.8.0_222*”
  • I was using openJDK (version 1.8.0_222), but I additionally installed JRE 8u231 from Oracle and selected it in LO. That too had no effect.
  • I read somewhere that for firebird to work, tools > options > libreoffice > advanced > experimental features has to be switched on. No effect.
  • I completely removed LO, fixed broken packages (not sure if there were any), installed again from ppa. No effect.

I’m stuck now, how do I proceed? Where do I get the correct sdbc-firebird drivers (if that is indeed the problem)?



In order to insure a working set, went to my Mint 19.2 Cinnamon system and did the following:

  • Removed all LO - renamed user profile; deleted LO (all traces)

  • Updated system & re-booted

  • Had OpenJDK installed & left it - system update brought it to v11

  • Added 6-2 PPA

  • Performed sudo apt-get update

  • sudo apt install libreoffice

  • Opened Writer. About =

    Build ID: 1:6.2.8~rc2-0ubuntu0.18.04.1
    CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: x11;
    Locale: en-US (en_US.UTF-8); UI-Language: en-US
    Calc: threaded

  • Opened a Firebird Base file. Got error message:

No SDBC driver was found for the URL ‘sdbc:embedded:firebird’.

  • Used Synaptic package manager to install:


All worked after install

And yes, it is realized Mint 19.2 is based upon 18.04 but Synaptic should provide the correct driver for your system.

@Ratslinger: thanks again! At first glance I don’t see a step that you did that I hadn’t done as well, though probably in a different order. Your last step never work for me, Synaptic Manager refused because ‘Depends: libreoffice-core (=1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.2.8~rc2-0ubuntu0.16.04.1 is to be installed’. I tried fixing broken packages, but it said there were no broken packages. I tried every way of fixing broken/orphaned packages that I could find on the internet, but that didn’t help either. In the end I removed the PPA version and re-installed the downloaded version, because I’ve got to get some work done. I’ll try again later and let you know. Tnx for your efforts!

@Ratslinger: So yes, the PPA and the version on the LO website are clearly not the same. I never got the PPA version to work because synaptic refused to install the firebird driver, while the version on the website already included the firebird driver (and also more icon themes and probably some other stuff). I don’t know why your solution didn’t work for me, maybe becaue different Mint versions, or maybe weirdness on my system (which there definitely was). Not sure now if I should accept your answer or not. Tnx for your input.