Base:Report ignores font assignment

My problem is similar to a posting from 2015. After I upgraded to Windows 10 and installed a new version of LibreOffice (, my reports in Base are no longer formatted correctly. Even though I specify Arial-12pt font in the report definition, the fields in the produced report apparently come out using the “Device Font”. Many of my fields look jumbled with the end of a field overwriting the beginning.

If I click on Edit to edit the produced report, “Arial” appears in the font selection box in italics. If I move my cursor to the font box the message “Font name. The current font is not available and will be substituted.” appears. If I attempt to select a font, the only choices are Device Font 10, 12 and 17cpi.

But, if I enter LibreOffice Write directly, Arial and numerous other fonts are listed as available.

Does anyone know how to fix this?

This is not a solution, just a general hint:

LibreOffice Tips & Tricks: Replacing Microsoft Fonts


Do not see a problem on Win10 Build 18363.x with LO v7.0.4.2 (x64)

Windows 10 is a clean install and not an upgrade.

Edit: Upgraded Win 10 to Build 19042 and still no problem. You may want to try resetting your user profile → see this post.

Ok, I tried running in safe mode as suggested there, but that didn’t fix the problem, so it’s not the user profile.

It’s not that Base can’t find the fonts, because in the report definition panel I can select different fonts and they appear to be applied correctly for example to label fields in the definition panel. But then in the produced report the letters seem to spaced much more widely apart than normal, and when there isn’t enough space for the widely space entry in a field the rest of the entry appears to be wrapped around to the beginning.

Go to the edit mode of your report.

With me:

Version: (x64)
Build ID: b585d7d90ab863bf29b2d110c174c0c2a98f3ee4
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Problem solved – I was telling LibreOffice to print to a printer that had been installed with a driver that provides only for ASCII text input. Output on a newer printer is OK. Sorry to have bothered you.

Thank you for posting the actual problem/solution.