Base Runtime Error

I am creating a report in design view in LibreOffice4. All went well until I suddenly got the following error when trying to resize a box label or picture:

Runtime Error!
Program:C:\Program Files (x86)\LibreOffice4\program\soffice.bin
This application has requested the Runtime to terminate it in an unusual way. Please contact the application’s support team for more information.

I closed accordingly and followed the recover file procedure when starting up again. It did not recover to the level where I had previously been so I made the changes again. Again it brought up the same error. I closed again. I opened again without running recovery and made one or two changes where I clicked save after each change. I tried resizing again and again got the error. Closed down. Start up using recovery and again it does not recover to my last changes either. I now cannot do anything as I keep getting the error.

Please help asap?

Couple of possibilities -

Are you updated to 4.1? If not, try that since there were some report crash fixes in the 4.1 version.

Make sure that you have selected a valid Java environment – Tools/Options/Libreoffice/Advanced and you might want to uncheck any Optional (Unstable) Options.

HI John

Yes I downloaded 4.1 to start with. Just checked and I have a valid Java environment - JRE installed from Oracle version 1.7.0_21 and NONE of the optional options are checked. Problem is still there.

Ronelle, This sounds like a very frustrating situation without any nice clean solution. I tried experimenting with building a report in design view and cannot replicate your problems. I am using LO and Windows 7 64-bit with JRE 1.7.0_25 32-bit. It is important that you have the 32-bit version of JRE installed (the 64-bit version can also be installed, but LO apparently needs the 32-bit version.)

I think the next step I would try would be a complete uninstall and clean reinstall. ugh!

I have the exact same problem with I literally cannot resize anything with dragging or it instantly crashes. However, I can resize using the properties form and changing the values there. I can pretty much do anything in the report design view except resize things by dragging their edges, which instantly crashes the program.

So I tried creating a new database with a new report to see if I could resize things. No problem there. I was originally following a tutorial video series when creating my report. Once it reached a certain level of complexity the resize dragging crashed things. I downloaded the author’s own ODB file accompanying the tutorial and tried dragging in the finished report there. Same result, insta-crash. I can only assume this occurs once the report layout becomes sufficiently complex.

Tried Same problem. Get the file here:

Click the download link @ Video 76 - Home Invoice pt4a - The Invoice – “Click Here To Download odb76-Invoice-pt4a-TheInvoice.odb”

Hope that helps somehow