Base: Some data from table doesn't show in the form. Why?

Libre Office for Mac
I am adding info to a new table bit by bit. The latest info I have added doesn’t seem to show up in my form. So when I tab thru the records in the from some records show entirely. Some only show partially. Any ideas?

Second part perhaps related to the problem above: One of my form headings ,“Price”, is gray in color. It seems to work ok but I didn’t go set the color of the font differently.
Thanks in advance for any suggestions!



Problems such as what you present are difficult to address as described. It would be best to attach a scrubbed sample to see where the problem(s) may be.

You can edit your question and attach the Base file. See → How do I attach a file to my question/answer?

Hi Ratslinger. I am having trouble linking the form and table. I follow the instructions…but when I try to browse the files to find and attach them I can’t find them. I can see LO in applications but not the files I need. Suggestions?


Not certain about your comment. What you are attaching is the entire base file (without personal or confidential info in it) and not just a table and form. It is your Base file: xxxxxx.odb

@Jackbootthug : how long is the field for the information you are attempting to store ? Could it be that you have reached the character limit of the field type, and that any excess is simply being cut off, i.e. not written to the database ?

@alex Thurgood: Thanks for this suggestion but no, I doubt that is the issue. I have check the field types and there seems to be no issue. Also, if there is a problem, nothing shows. It’s not just partial.

@ratslinger: Thanks again for your help. I had to put the project down for a while but now back at it. I do understand what you meant. I am certainly familiar with attaching files and the data that is in there isn’t sensitive.

But for some reason the process oof attaching an ODB file is not obvious (which probably means it’s staring me in the face).
I try to edit my question as you suggested. I click on the paper clip. I’m given a box to browse for the file. But that is where I get stuck. I can’t see where to go in browsing to find the file. I even tried to save the file to “desktop” but that doesn’t seem to work. I’m sure it’s easy…but it’s not obvious.

@ratslinger: I think I was able to upload a file with dummy info. Hopefully you can view the table and form. Back to the main issue the description that is in the table doesn’t show in the form. I can’t figure out why.
Less important is why the color of “price” in the form is gray? But at least it works.

Further observations: I have a table name product info. It’s generally complete and what I think my form should be linked to. However, for forms, I have two. One is “frmproductinfo2” which I have designed for viewing and input of data. This is where I’m not seeing the data for “description”. The other part under forms is just called “product info”. Here description is almost empty so I suspect my good form is linked to that for some reason. I don’t recall making this and I don’t see where I can check the link. But I think with this is the problem Should I just delete “product info”?


It appears you figured out how to post the file. However during the process you may have inadvertantly hit enter or another key and broken the link so we still can’t get the file.

Please repost. Resulting link is aqua in color.


Not sure what you did, but did I try to open as Image and was able to download the file. Think you are using the incorrect icon to post.

Will look at shortly and see about a response.


Well after all that time it actually only took a few minutes to solve the problem.

From what I see there are two similar issues - both related to Description on two different forms. You must have changed the field name at some point. In each of these the field name assigned to the control is DESCRIPTION but the field name in the table is actually DESC. Change those & the data displays without a problem.

The font problem for Price label and data field is it is set to Bold 12 pt in each controls properties where other fields are Regular 11pt. You also set each of these under Enabled to No.

Changed Frm PRODUCT INFO2 and PRODUCT INFO forms with above notations.

You should avoid using spaces in any naming convention. Better something like frm_product_info or similar.

Returned sample ---- Repaired_AMS_Chain.odb

Also fixed your attachment. There was no space between the ! and the inserted download. Always try inserting on its’ own line.

Yes, you solved all. Thanks for your time and patience!
But I noticed in your “repaired_ams…” that the form still seems to read Description. So where is it exactly that needs to be changed? I went to edit form> selected Description> enter group> right click for control. I don’t see the correct Desc in label or name. So how does one navigate to the part you changed?

Noted the other suggestions.
Thanks again.


It seems you are not very familiar with accessing methods. On Your forms, when editing the form and clicking on DESCRIPTION then right clicking you are selecting two controls. Note that the Properties dialog states “Multiselection” at the top. You have actually selected both the label control and the text box. With that only common information is shown.

Instead hold down the Ctrl key when left mouse clicking the field. This will select only an individual field. Do this for the Text Box. Then you will find on the Data tab the field name referred to.

Please review the Base documentation → LibreOffice Base Guide

Also, as you have been helped, please help others to know the question has been answered by clicking on the :heavy_check_mark: in upper left area of answer which satisfied the question.

You’re correct about my accessing issues. I’ll try your suggestions. Thanks for mentioning the check box.