"BLANK" as page No. 1 in Writer. . . but numbering 2, 3, 4,etc. continues for pages thereafter

I am enjoying using Writer, but have a problem when I need to have a “BLANK” (or nothing) as the page number on the first page of my document with number “2” showing on the next page (i.e. page 2) and so on - mainly on legal documents where the page number “1” is not to be shown on the first page (as the page may have the Court Title, document title e.g. AFFIDAVIT, AGREEMENT etc; but thereafter every successive page of the same document needs to have its respective number starting at page “2” and so on.

I find these page break suggestions rather very cumbersome and difficult to use.

May I please suggest that your code in Writer could have an option for “Different First Page” just as Microsoft Word has. The entire page break routine could be “bundled in a macro” in the Writer software code and we could be given a simple option in the Writer-Layout-Page Number-BOX “Different first Page”. This could then be ticked as and when the user requires page numbering in this manner.

Kindly see what best can be done to help with this.

Thank you.

There is a page style named First Page which should do what you want. Set your first page to that style, which by default does not have a footer. Following pages by default will be Default page style, which you can configure with footer and page numbering.

Hi @robleyd,

Thank you for your suggestion. I tried it out, but unfortunately it does not work in the latest version of LibreOfffice 7.6.3 Writer, that I installed this morning.

The 1st page blanks out as rightly suggested by you, but the subsequent page numberings do not begin at 2, 3, 4. . . .

Again, I feel the whole routine has to be re-jigged by the software developers, as it is rather cumbersome to use.

But thanks again.

No, the whole page routine need no re-implementation. It offers tremendously powerful features not available in Word which you seem to be familiar with. The main problem here is to accept to forget everything you know about Word and learn the different principles upon which Writer is based. You should start by reading the Writer Guide.

Regarding your page numbering problems, there are two main solutions:

  • several page styles
    This solution has been described by @robleyd. Use First Page for the first page. Following page are automatically Default Page Style. Then handle your headers/footers separately.
  • single page style (simplified design for easy cases)
    You have the “different first page” option in the definition of every page style. This is probably similar to the Word feature.
    Open the page style you use in your document (likely Default Page Style) and go to the Header or Footer tabs. You have 2 check boxes there: Same content on first page and … on left and right pages. Untick the box to detach the corresponding item from the “global” setting. Back in your document you can arrange the detached element separately from the running pages.
1 Like

Heh, it works for me - so is it really “cumbersome”, or did you omit all the information like “I did this and that, and pressed here, and I see this in the result”, which would be required to see what you did wrong?

Because the process is as simple as:

  1. Create a new document;
  2. Double-click on “First page” page style in the styles manager (F11);
  3. Type as you need;
  4. As soon as you arrive to the second page, and see that you need a footer with the page number, you add the footer by hovering the mouse over the respective area and clicking there to see the controls;
  5. You add the page number field there in the footer.

Is this the direct and plain implementation of the respective idea?


Hello @ajlittoz,

Thank you for your kind response. Please note that I need my page numbering in the Header only.

Your solution was partially effective. . . and I really thank you for your kind help, BUT I still need your support, and I will explain as follows :

I tried the second-alternative, as suggested by you, namely : “single page style”, and I did the following : On the first page, I right-clicked and went to “Page Style”-Organizer tab : First Page ;
Next I went to the same dialogue box tab “Page”-Layout settings-Page Numbers-NONE
Next I went to the same dialogue box tab “Header on”- (unticked) . . . the 2 nos. boxes, left & right and First pages remained OFF. - Which means GLOBAL DEFAULT STYLE not applicable for the first page.

Then : type, type, type to page 2.
NOW I once again right-clicked on the page 2, and went to “Page Style”-Organizer tab : Default Page Style ;
Next I went to the same dialogue box tab “Page”-Layout settings-Page Numbers-1,2,3…
Next I went to the same dialogue box tab “Header on”- (NOW ticked) . . . With the Same content on left & right and First pages box ticked (i.e. both now ON)
- Which means GLOBAL DEFAULT PAGE STYLE is now applicable from the second page onwards.

NEXT, I right-clicked on the page 2 blue header page tab and chose “Insert Page Number” and typed “2” + CTRL “E” to centre this number in the header.

BUT the ONLY the consecutive EVEN pages from page 3 onwards returned continuous page numbering as 4, 6, 8 . . . etc., and all the ODD pages had no numbering on them.

Please suggest how I could fix this.

You probably messed things up with Insert>Page Number which launches a “wizard” (a set of macros which directly modify settings in various “objects” and certainly add direct formatting to your document). I rarely trust such “wizards” because I don’t know exactly what they change and where. Wizards are offered for those coming from other suites (mainly M$O Word) too lazy to read the documentation and still following their inherited routine.

Applying twice the wizard has probably aggravated the situation.

The description of what you did is not very clear. Here are a few leads to fix the issue:

  • tab Page in the page style has a global effect
    It can’t be “customised” for first, left or right pages. Anyway, all settings here don’t make sense separately.
    • Page layout tells the nature of the page controlled by this page style
      • Right & left (or Mirrored, but this only changes the behaviour of margins): “ordinary” pages
      • Only right or Only left: specialises the page style for one side; if the page style is not associated with another style for the other side, you end up with printing every other page
    • Page numbers: configures the appearance of the page number in all pages laid out with this page style
      This will be the default format for the page number field.

Your choice is Right & Left because the other choices are intended for special effects and you seem to only begin with Writer (no offence intended, everybody starts as a beginner). Keep the default 1, 2, 3 as this is what you want.

  • tab Header can be configured globally
    No need to wait to have page 2 because, once again, the setting does not apply individually to pages (which would really complicate things). It applies to the sequence of pages controlled by the page style.
    In you case, tick Header on. Untick Same content on first page and keep Same contents on left and right pages ticked.

Once this is done, you won’t modify again the page style. You can go back to your text.

In the first page, click in the header area. It is easier to locate the various areas if you enable View>Text Boundaries and also View>Formatting Marks for better awareness of what’s getting on. These clues don’t print. So keep them enabled.

Erase anything which could be there.

Go to page 2.
The header is styled by a built-in paragraph style which is already configured for left, center and right “annotations”. Press Tab to send the cursor at center. Insert>Field>Page number bypasses the page number wizard (and therefore does not ruin your manual configuration) and simply inserts the page number.

Before doing this, it might be wise to select the whole text with Ctrl+M to remove all your added direct formatting. Do the same on the existing headers.

Hi @ajlittoz,

Thank you for your prompt reply regarding the partial page numbering problem regarding the ODD page numbering that got me struck earlier today.

While I am grateful for your valuable inputs, one has to be diligent to understand the software, as we are all on an initial learning curve when dealing with a new program such as Writer, and yes, it does take some advice from experts like you, some effort to personal experiment with various options, and once it works the method sticks with the new user. . . . much like a new language… . ! :slightly_smiling_face:

So I have now resolved, for myself, the issue of ODD pages being numbered consecutively and automatically, by simply right clicking on the page 3, and went to “Page Style”-Organizer tab : Default Page Style ;
Next I went to the same dialogue box tab “Page”-Layout settings-Page Numbers-1,2,3…
Next I went to the same dialogue box tab “Header on”- (NOW ticked) . . . With the Same content on left & right (NOW TICKED) but Same content on First pages box NOW UNTICKED.

Then I right-clicked on the page 3 blue header page tab and chose “Insert Page Number” and “3” appeared automatically + CTRL “E” to centre this number in the header.

And VOILA !!! all the ODD pages 3, 5, 7, . . . etc. have appeared given the page numbering completely as desired by me - with NO numbering on Page 1.

I will use this technique for all my future work of page numbering, as may be needed by me. I hope this technique will help many.

I am also hopeful that this rather cumbersome procedure “discovered” by me, with your kind help, for this unique page numbering requirement in Writer, will be made more simplified by the developers of Writer in their future updates of this very good software.

Thanks again dear friend @ajlittoz.

As I already said it, avoid Ctrl+E to center your header. This is direct formatting and will eventually create problems later if you need to add data in the header. The header had paragraph style Header applied by default. This paragraph style is already configured for 3 information bits at left (left justified), center (center aligned) and right (right-justified). Make benefit of this. Just press Tab before the inserted page number and it will jump to center without any direct formatting, preserving the properties of the other bits.

One absolute golden rule with Writer is Avoid direct formatting. Contrary to what newbies think, direct formatting is not intuitive at all and ia a faux ami. I know direct formatting is the only available procedure in Word because it lacks notion of character, page, frame and list styles, knowing only of paragraph styles. Direct formatting will always play nasty tricks on your back and prevent you from easily tuning the appearance of your document. Achieving good results with direct formatting requires super-expert skills (not only expert skills) and, this, at the cost of lot of sweat and pain.

Learn as quickly as possible to work with styles. I can assure you after many deceiving failures that styling (I should say semantic styling which is closer to author creativity) is really the most comfortable way to produce documents: you concentrate on your text and formatting is automatically taken care of by styles.

If I understand correctly, you want the first page of the document to not have a page number. You want the rest of the pages to have page numbers with the second page of the document beginning as page 2. You want the page number to appear centered in a header.

I’ll try to explain a simple process to obtain this.

First, open a new document.

Open the Sidebar if it is not open. This can be done by going to View in the Menu Bar and selecting Sidebar.

Open the Styles deck by clicking on the icon at the far right with the capital letter A and what looks like a paintbrush. At the top of the Styles deck are a number of icons. The fourth icon from the left is the Page Styles icon. Click on this. You should see a list of page styles with Default Page Style currently highlighted

The fourth style in the list says First Page. Double click on this style to select it. Your first page is now using the First Page page style.

Fill your first page with text until it overflows to the next page.

The Default Page Style should now be highlighted in the Sidebar. Right click on this and select Modify…. Go to the Header tab and click the box beside Header on. You really don’t need to worry about making any other changes on this tab. Click OK to close the dialog.

Now, click on the first icon on the left at the top of the Styles deck in the Sidebar. This opens the Paragraph Styles deck. You should see a list of paragraph styles with Default Paragraph Style highlighted.

Go down the list until you see Header and Footer. Click on the plus sign to the left of this.

You should now see two more paragraph styles listed below Header and Footer. Right click on the one that says Header and select Modify….

Go to the Alignment tab and select Center in the Options area. Click OK to close the dialog.

Click in the header area of your second page. The cursor should appear in the center. A light blue box should also appear reading Header (Default Page Style). Click on the small arrow at the right of this box. Select Insert Page Number. The number 2 should appear centered in your header.

As your text flows to the next page, a number 3 should appear centered in a header. Following pages should appear in a similar fashion with following page numbers.

Hi TXDon,

Thank you for your inputs.

You have shown me a much simpler and more refined way of getting my desired result without having to right click on three of the initial document pages and change the page styles each time.

I will remember this method and get used to applying it routinely whenever necessary.

Thanks again. Much appreciated.