Border option, in New Table Defaults, appear to be useless

The Border option¹ appear to be useless, given that, when choosing menu Table - Insert Table…, the default is Default Style (with borders).

Not yet reported in bugzilla.

¹ Choosing menu Tools - Options - LibreOffice Writer - Table, below New Table Defaults.

LibreOffice (x86); OS: Windows 6.1

Posted a bug report:

No issue seen at LibreOffice (x86); OS: Windows 6.1. Closing the bug report.

Thanks @Hrbrgr and @Lupp.

Yeah, some strange behavior.

Default setting:

It would be useful if you wrote a bug.

Please post the link of the bug here. Thank you.

With me Windows 10 Home; Version 2004; 64-Bit | LibreOffice, Version: (x64).

I cannot confirm this behavior with the released V7.0.0.3.
Both ways of inserting a table apply the same setting(without border) for tables not using any table style at all.
I cannot test with any V6.3, but I did with V6.4.5. Same result.

Anyway: Since the StyleFamily TableStyles once was introduced (good idea?), I would expect that every table has one style applied. If not one is explicitly assigned, this should be Default. Actually the default style for tables still has borders if the global option @Hrbrgr pointed to was used to disable borders, and there may have been versions or hidden settings to the effect to apply the Default style to tables newly inserted without an explicit style assignment. To keep a kind of property value like NoStyleAtAll should not be considered a good idea.
I suspect the rather young TableStyle feature to be insufficiently checked for consistency.
But I’m tired of reporting such issues as bugs. They are unavoidable under a policy of unlimited featuritis combined with a concept of compatibility forced upon free software by the strategies of commercial competitors.
Lacking financial power “we” cannot overcome as long as public institutions feed the monster.

BTW: The API also is treating the so-called table styles inconsistently. On the one hand there was created a new StyleFamily not containing a member "None" or "", but the respective property of any TextTable isn’t .Style or similar, but .TableTemplateName, and this is allowed to have the empty string as its value.
How to tidy that up?
[I did not check in what way, if at all, related topics are treated in ODF 1.3 (extended).]

Sorry, I have to correct. For me also version

How so? We got different behavior. Can you explain?

I have the Insert Table icon hidden (Standard toolbar), so I had no tried with it.

Now showed the icon (promptet by @Hrbrgr answer), and YES: When Border option is checked, using the icon creates a table with borders, and if Border is unchecked, creates a table without borders.

But always, choosing menu Table - Insert Table… or Ctrl+F12 or clicking Insert Table icon and choosing More options… open the Insert Table dialog with Default Style (which means borders).

Insert Table dialog

So: Will I file a bug? In which terms?

@Hrbrgr: See attached.
Concerning the mentioned additional bug: The dfeferred pasting did no longer show when the file once was saved. (Should I have expected this?)

(Should I have expected this?)

The world is full of wonders. :ok_hand: Thanks for Information.